Room Lighting doesn't show new variables

After creating a Room Lighting automation, I found that I wanted to limit when it would activate. I created a new boolean Hub Variable, then went back to my Room Lighting entry and selected Means to Activate Lights > Activate Lights Options > Limit Activation under these Condition (Variable is true) > Don't Activate when Variable is true. However, only the boolean variables that were created before this Room Lighting were listed.

As a sanity check, I tried creating a new Room Lighting automation. Yep, it shows my new hub variable.

Went back to my original Room Lighting to check. Nope, new variable still isn't there. Even tried rebooting the hub.

Is the only solution to delete the Room Lighting and re-create it?

Try hitting "Done" in that child instance and re-opening it? Or maybe "Done" in the parent Room Lighting app? These are cached at some point, but I don't know when they are reloaded exactly or what can trigger that. You should not have to re-create.

All you have to do is hit Update in the app to refresh the list of variables.

What does "update" actually update? The way its in-between two controls about Debug logging, in addition with Activate and Turn Off , it's confusing.

Is Activate/turn off about debug logging too?

You have a scrunched UI view:

Activate activates the lights; Turn Off turns them off.

Update re-initializes the app, and refreshes variables, subscriptions and schedules.

Interesting. I'm just viewing it in the mobile app remotely. Its sizing it oddly then?

UX suggestion:

  • Put the Enable Logging and Debug Logging next to each other in a row.
  • Turn Activate and Turn Off into a single toggle.
  • Move Update down as last, or maybe even next to Done, as its a "update/commit the rule but stay here" vs "update/commit the rule but return back".

Thanks!

It's ultimately quite tricky to get these things to render optimally for all screen sizes. You'd even see a difference between portrait and landscape.

1 Like

Download the Hubitat app