Room Lighting App to Only Turn On Certain Lights After a Certain Time

I have the room lighting app programmed to turn on all my kitchen lights when motion is sensed by a Hut Motion sensor. I have a schedule that varies from depending on the weekday/weekend and time of day. The later in the evening setting is only supposed to turn on certain lights (not all the lights). The app works the same regardless of time (all the lights come on). Did I program it wrong? I unchecked "Act" from the lights I didn't want on.



On the Activation Settings, make the ones you want off to be set as Off.

1 Like

Got it. I thought unchecking act would cause the lights not to turn on. So I need to have act checked and switch the activation setting to off?

You will want to add that to make sure they turn off. Leaving the ACT unchecked means they won't be updated by the app. Checking ACT and setting it to off will turn the lights off when the period starts.

You'll want to make sure you have the activation option for "activate at period start" enabled as well.

1 Like

Lights still all come on even with the below changes.

The original setup actually looked correct to me, at least based on what I understood from your description. What I would do is enable logging for this Room Lighting instance, then see what Logs for this app show at the appropriate times.

Speaking of times, I'd also make sure it's really within the time period you think it is, as that could, of course, also cause unexpected results...

2 Likes

@bertabcd1234 is correct and I was wrong after reading it back over. My suggestion would turn the lights off when motion is activated. Sounds like you just don't want them to turn on. If it is the latter, then the original configuration was correct.

1 Like

This is how I have mine setup that works. I use modes. But the concept is the same:

They worked after I included "Adjust Lights on Time Period Changes" under Activate Light Options/Additional Options