Room Lighting Activator bug

C8 -
I have many groups in Room Lighting. There are no rules, I just want the Activator Group.
Turning things on and off always works.
I have tried multiple ways to dim (fade, set level) an Activator through WebCore and all I get is a plain OFF. I have tried various delays but the only thing that works is addressing the bulbs as individual devices.
I also note the Actuator never has the current value, you have to press Update, so maybe this is what's confusing WC?
Means to Turn On has a delay function but Means to Turn Off does not.
Am I missing an intricacy here buried in the RL options of the rule or does this action not work for Activators?

I would start by sharing a screenshot of your Room Lighting setup (corresponding to one of the activator devices in question) and possibly your webCoRE piston.

Have you checked your devices to make sure the Room Lighting Activator device is correct? If it is only give you on/off, I wonder if the device is set to a switch rather than bulb or dimmer.

Also, in the Room Lighting group itself, are the device types correct too? This will affect the activator device as well.

Devices are all Sengled Element Classic around the house. They all dim on an individual basis Using the built-in Advanced ZB Bulb driver.
Activator is populated with them as Dimmer.
Maybe it's one of these options that's screwing it up?

First thing I would do is change the device type on the Room Lighting table. Click on Dimmer and change it to either CT or RGB depending on the type of bulb you have. After that is finished and saved, go into the devices tab and look for the Master Bedroom Beside Group. I’m preferences, change the activator type to bulb. Once everything is saved, see if it now works.

Thanks for the other brain nudges. Poked around your suggestions and noticed that I didn't know the Activator device could be set to Dimmer as well.
I tried that as well as CT. CT didn't work but the Dimmer Device setting made the Fade command actually do something. Set Level just turns off the bulb no matter what device type it is; just doesn't work. :frowning:
Thought I had it but every time the Fade got to Set Level 0 the bulb would go off and then blink back on even though the Device driver said it was Off!
I piddled around trying to fix the Fade with forced Waits and Turn Off commands but no luck.
Deleted everything back to just Fade to 0 in 2 seconds and now it's fading and staying off.
Dunno but I'll give it a few nights of real world testing, fingers crossed HE was just out of sync for a bit and it was just the Activator not being switched from Bulb to Dimmer.

I think having them congruent will definitely help the situation. Room Lighting is treating your bulbs as dimmers (based on type in the table) and now the activation device is also a dimmer.

As for set level, does that work from the device page of one of your bulbs? I’m pretty sure your driver accepts that command so both bulbs should be responsive to it. Assuming you can do set level from the device page of one of the bulbs, you should try setting everything to CT (activator device and the type in device control within Room Lighting).

I've found that CT doesn't work as expected, at least with my Ikea Smart Bulbs.

They would turn on/off, but wouldn't change to the light level indicated by the Mode/Lighting Period.