RM5 Rule Has Stopped Running

Not sure I understand what is wrong, and why this rule has decided to stop running. This happened about a week ago; when I click on Run Actions within the rule, everything works as it is supposed to.


Any ideas?

UPDATE: A Simple Automation Rule has Stopped working as well


(Yes, Xmas Tree. Don't judge)
Could this be a time of day issue?

First, as far as I can see, there is technically no conclusive evidence that either Rule isn't running. The fact the desired actions aren't happening could be a number of reasons, among them a device or network issue (including a sporadic issue, so the fact that it works if manually run isn't conclusive, either). Turrning on logging for the Rules is really the only way to say that with confidence, so that's what I'd recommend if these continue to be problematic.

That being said, it's possible something got messe up in the schedule for both. This shouldn't normally happen, but opening the RM Rule and the Basic Rule and hitting the "Done" button should re-initialize those and fix this if it is indeed the problem. (If you want a better guess as to whether it is the problem, opening the "App Status" page for the Rule in question--the gear icon--should have something under "Schedued Jobs" whose next run time or schedule would make sense for the Rule, though it's often hard to say exactly what these do if you didn't write the app.)


Will definitely turn on the logging for Rules. Couldn't find where to do this, but will look again.

In Rule Machine, it's on the "main" page for the Rule. Trigger and Action logging will probably be the most helpful, but all doesn't hurt. In Basic Rules, is an option just below the part that was cut off in your screenshot.

I'd still probably just hit "Done" in both to re-initialize in case something with the schedule was indeed messed up.


so, still having issues with the RM5 Christmas tree on rule.
It has not worked since I rebuilt it in RM5 (instead of simple automation)

The event log is always empty.
Scheduled Jobs show it is ready to go for next morning

I do not see any logs for the rule, even thought I have chosen to log Events, Triggers, and Actions

Here is the rule.

I am at a loss.

These show up under "Logs" in the main admin UI, not the App Status page for the Rule (which is where it sounds like you might have been). While catching it live is possible, you should also be able to see a few hours or so of past logs on this page (exactly how much depends on how log-happy your apps and devices are, as it is capped at a certain size). So, if it's still close to 6:30 AM your time, you might still be able to look for something there.

Your Rule and the job it scheduled look fine to me, so I'm not sure what could be going on. Outside of logging, you might want to verify that the "Christmas Tree" switch responds to "On" commands as expected, perhaps by playing with it on the device page. But Logs are the answer to what Rule Machine is doing.

It never appears in the Logs in the Main section. Maybe I am looking in the wrong place - I am looking at the titles on the top, and not in the list below.
And I turn it on manually every morning myself.
I did notice that the automation of the switch stopped on Nov 3rd.

I have another rule which stopped working on Nov 3rd as well

Maybe something wrong with Rule Machine? But then it would affect other rules that have always worked

Unless it logged something while you had the page open, you won't see it under live logs, but you should indeed see it under past logs. The title, if we're both thinking of the same thing, would be the Rule name. So, if it's not there, something is odd (unless it's been too long; make sure you're able to see this far back if you use the "load more..." feature).

Hitting "Run Rule Actions" in the Rule should also log the actions (not thr trigger since you're doing this instead of a trigger event), so just to test logging, at least, that is one way.

So, I clicked on run actions, and yes the log appeared in the list.
Both rules. So logging appears to be working correctly.

I will play around with the times in the rule, to set it later today, to see what I can capture as it is supposed to run.