RM4 Rule didn't trigger

Twice in the past 2 weeks, walk into the Master Bathroom and the motion is detected, light doesn't turn on.

Viewed the logs, confirmed the above, motion detected at the device, correct mode was set, the rule never ran. Reboot the hub, now it works...

C-3, FW: 2.2.3.148

I don't seem to recall the general randomness since joining Mar '18, is this the new normal?

1 Like

Same here. Something is slowing down the hub. Sometimes I have to wait a full minute for lights to come on. In my case the zigbee network kept going offline. Some device is either not reporting or not responding. I narrowed it down by manually turning the light on with my phone, since the light was responding I knew it had to be the motion detector. Odd thing is, was working fine for months and then decided to act up.

Post the logs, let's see what's going on.

In this case, there is nothing to post. Since the Rule didn't fire, nothing was recorded... I see motion was detected in the log but that's it.

Once I rebooted the hub, the Rule fired and recorded just fine

Guessing you checked for failed pairs by looking at clusters in zwave settings and nothing unusual in stats?

http://hubitat.local/hub/stats
http://hubitat.local/hub/enableStats
http://hubitat.local/hub/disableStats

Hmm, It's too late now but at failure time, I would have looked at the event subscriptions under the rule(gear icon)
and see that the rule was subscribed to the events correctly:

Just as another data point, I have never had this happen with motion lighting. If the lights didn’t turn on, it was usually due to either the rule thinking the lights were already on, ie. Turned off by something that the rule wasn’t watching and the timer hadn’t expired yet, or the motion sensor (or Zone Motion controller) hadn’t reset yet. For my problem areas I have enabled “turn on if already on” in ML or adjusted timers in Zone Motion controller which has fixed it.

Hey all

Appreciate the responses...

Happened again last night but with a ML app and he is my conclusion

ML app says it didn't turn on the light b/c it was already on which it wasn't.
There are 5 motion sensors which are used in 3 different areas to turn on 2 lights so it wasn't for lack of detection or reset

I believe it's b/c in both cases (here and the original post), the light switch is Z-Wave (non-plus) and very likely not reporting properly to HE

Woke up this morning and the ML rule worked fine

Didn't get a chance to check the subscription for the ML rule last night so I will have to keep an eye on it

Any other thoughts?

@toy4rick It's an unfortunate result of regular zwave devices not reporting the status. You could poll the non-plus device and it would update the status but keep in mind that polling is very chatty and can slow down things if you have to poll more than just a couple devices. Ideally, you'd want to swap out that non-plus for a plus. If you go to settings, zwave details, and look in the clusters column... All of the zwave plus devices will have 0x5E as the first entry. An easy way to identify what devices are plus or not.