RM rule generating error

@bravenel the rule below is set to turn on heat in my bathroom in the mornings, It hasn't ran since last winter and I have modified it. I updated it to a 5.1 rule to use hub variables and other options not available in the legacy RM. I re-wrote from the original rule which worked well. There may be some issues, but it didn't get very far into executing the rule before it generated an error and stopped. See below. I don't see any issues in the rule, perhaps someone else will.

What release are you on?

Please post a screenshot of the portion of Application State from App Status page that shows the bottom portion of Application State.

I am on, haven't had a chance to do the last one yet.

I think this is what you're asking, is this enough of bottom portion?

It appears to me as though the Wait for Expression action has been corrupted somehow. Please delete that one action, and recreate it. Then post the same thing as the very last screenshot above.

Please post a similar screenshot, but for the very first part of Application State, where the a's are listed.

Try it, I think it might work.

It's set to run again in the morning, If I get a chance tonight I will set it up to run tonight.

It did run this morning. I tried it last night but realized when I added the line back I set it as a duration instead of a timeout, and I didn't have time to try it again, so I just edited and decided to wait and see if it worked this morning. So apparently the editor corrupted the rule for whatever reason.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.