RM Rule fails to run

Platform version is 2.3.1.142

Here is an RM5.1 rule used to work but now is not running no matter
what I tried (first Hub Reboot followed by Soft Reset + DB Restore):

This rule was running for a long time but now I cannot run it even by pressing
"Run Actions" button. Recently I modified this rule a bit.
First IF use to be a Required Expression.
All rule logs are turned on but log is absolutely empty.
First I tried to Clone this rule. This did not help.
Then I reboot a hub. This also did not help.
Finally I performed Soft Reset + Restore.
And even this did not help.
@bravenel Before I will delete this rule and re-enter it from scratch do you
want me to do something for the debugging?
Sorry, but the related LOG is 100% empty.

I guess, I have few more suddenly refuse to run rules with no apparent reson
for this.

Post a screenshot of the first potion of Application State from the App Status page (gear icon). Looking to see the A's from the alphabetic list.

Here it is (I hope this is right one):

I see no reason this rule wouldn't log something. See PM I am about to send you.

I found the problem. Previously, you had a Required Expression that you have since removed. As part of that you had selected 'Cancel pending actions when Required Expression becomes false'. When you removed the Required Expression, that toggle was still selected. This prevented the rule from running.

First of all, this is clearly a bug, and that toggle should be cleared out when the Required Expression is removed. Were that fixed, this rule would have run as expected.

In the meantime, to fix this is easy. Select Use Required Expression, and create any quick meaningless Required Expression. Uncheck that toggle, and then remove the Required Expression. The rule will then work as expected.

First of all - BIG Thank you very much for the idea how to fix this rule
and very quick response.
I may have few more rules like this.
As of now I actually recreated this rule from scratch and of course,
it runs as expected.
I guess, the debugging is over and I am free to delete not working
rule instance?
Right?

1 Like

No need to delete, unless you really want to. Just follow instructions above to clear out that one setting.

Download the Hubitat app