RM not recognizing (and can't set) thermostat mode (Workaround Found)

Update 11/16/23: I figured out a workaround that may help others and note it in a later post, below. Hope it helps someone else reading this.

I have a driver that in past firmware allowed me to set the mode (heat/cool/off) and temperature set point for our Daikin mini-splits. Using RM 4.1 and with 2.3.5, I could do either or both of these things, AND make the change dependent on a thermostat mode condition (i.e., "set heat point to x IF thermostat mode is heat", or "set thermostat mode to off at x time, if mode is heat"). I tried to create additional, similar rules using RM 5 (current RM under, but it won't recognize a condition of thermostat mode. When I try to select it, no mode options are shown other than "No selection".

It appears that this is now broken in RM 4.1 (RM Legacy) as well, as I just tried a rule that formerly worked well, and it now does nothing. I can set the heat set point using either RM 5 or RM 4,1, but the moment I try to set mode it doesn't work at all. So, it appears this new firmware can't make use of my thermostat modes. Ideas? Seems like 2.3.6 just keeps on giving...

Please post a screenshot of the device Current States (it may be the supportedThermostatModes attribute not properly sent by the driver).

Can you change the modes from Hubitat dashboard 'Thermostat' tile?

Check out this post, may be related.

I cam across the same issue.

I have a virtual thermostat created for my home office that uses a temp sensor to read current temp and a smart plug to turn on/off a space heater.

I wanted the thermostat mode to be set to off when I turn the lights off in the office at the wall switch or if wr leave the house but although rule machine looks like it has the capability to do it, when you build a rule with the action set mode to off, when you select the mode in the drop-down nothing actually stays selected so the rule doesn't work.

Once again, show the Current States from the thermostat device page.

Rather than post info about the device, which I frankly didn't think would offer much useful info, I've been experimenting with alternative approaches. I found one that worked for me, and offer it here in the hope of it helping others.

I ended up ignoring the path of selecting an action based on setting a thermostat, and instead went down a path of "custom action".

There's a choice under Actions of "Set Variable, Mode or File, Run Custom Action". I selected that, then "Run custom Action". That pops up a drop down list that says, Select Capability of Action Device", and "Thermostat" is one of the many options.

That allowed me to select the appropriate thermostat, and from there I was given a choice of many different options that included the thermostat mode I needed, "heat".

I could then use this same approach to create an additional action of "setHeatingSetpoint", then enter a parameter of "number", and set the thermostat to the desired setpoint. In my case, I delayed that second action by 10 seconds to allow the mini-split to process the command of going into heat mode before it was forced to accept a temperature setting. That may or may not be necessary, but it worked.

To be frank, this is a pretty darn convoluted approach, when the logical path would seem be to select the action of "control thermostat". That doesn't work anymore (it did in the past), but the approach I outline here does, at least for me. So, I hope this helps someone else. I'm personally finding that "custom attribute" and "custom action" is necessary more than I had imagined I'd be using them, for the devices and Rules I find I need. Others' "mileage may vary".

I'm not going to claim to know what @bravenel is wanting from the current states for the device, but I expect he will have a good reason. From my own experience with thermostat drivers I will make an educated guess he is wanting to know the supported modes, but there's likely other info that may play a part in this issue.

I can only add that I have 4 virtual thermostats currently running in my system. All seem to be running as they always did, with no issues. The control thermostats action in RM works for all 4. I just tested each one. I am running the latest release.

Actually, that was needed to determine one possible explanation for a problem with these. As it turns out, you don't have that problem.

I'm not seeing this problem, as in, this works for me:

After creating that action, the result is:

Hi @bravenel, maybe it's becuase it's an existing Legacy Rule Machine rule I'm trying to modify but when I add an action to set the thermostat mode, I choose the option off as per below:

as soon as I select it in the dropdown, it appears like I made no selection at all:

and then the rule reflects that no selection was made:

1 Like

It appears there is a bug in Rule 4.x with respect to setting thermostat mode (never updated when thermostat mode attribute was fixed some time ago). You'll have to recreate the rule with Rule 5.1.

1 Like