RM 5.0 Volume By Variable "invalid"


Just started noticing this in several of my existing rules after latest release.

Looks like it is specific to RM 5.0 rules

Rules still work, however

1 Like

That was fixed in 112. Are you still on 111?

Nope I'm on .112 problem still there

Edit the action, hit Done Editing.

Tried that already, also tried deleting the action and rebuilding it. Same results for me.

What kind of variable is Sonos Default Volume?

1 Like

Hub Variable type "number", also tried it with another"number" variable, same result

Roll back to Then update again. You're running on 111 somehow.

Rolling back now, will report back after I reinstall. FWIW every part of the UI says I'm already on .112 weird.

What else? This one thing you're seeing is 111, not 112. There weren't many changes in 112.

Notifier got Local File option for text notifications.

RM version for 112:
Screen Shot 2021-11-25 at 8.37.35 PM

the hub information page claims .112 as well as the restore from the previous version page at 8081. Almost done with the re-install.

After rollback my 5.0 rules still show a RM version 11/23 my 5.1 rules show 11/24 like your example.

Is this a 5.0 rule? The bug is fixed in 5.1. If that was a 5.0 rule, then I can't say I'm surprised.

Duh, I missed that in your OP. I'm not pushing all of the bug fixes in 5.1 back to 5.0. They have two different code bases, and there are only so many hours to go around.

Yes, as I said in OP it's only my 5.0 rules exhibiting the issue. I'll rebuild them in 5.1 when I get motivated.


Happy Thanksgiving.

Not to mention you should be relaxing after consuming absurd amounts of food. Thanks again.

I saw this in 5.0 rules. Rewriting in 5.1 resolved the issue.

1 Like