RM 4 Rule Review to trigger Mode/Ring

Hello there,

Need a review of this rule that worked for a few days then quit working for no known reason

Mode manager is used to change mode from home to night at 9:30pm and back to home at 6:00am and at the same time, the Ring alarm should be set to home (night mode) and disarm (home mode)

Ring integration works fine from the hub device page to arm/disarm, tested and confirmed with @codahq

Rule appears to be seeing the mode change and setting Ring appropriately however the alarm is not changing

Thanks, Rick

Did you accidentally turn off the Sync function on the Ring Alarm Hub virtual device?

Hmmm, never touched it, yes it's turned off, so you are suggesting it should be on...

So then what good is the rule?

Guess I'm confused


@codahq, well just like one of my ring sensors that worked fine for several days then wouldn't change status until a hub reboot, now my Rule worked as designed. At 9:30pm just now, mode changed to Night and the Alarm was set to home

And no, I didn't change the HMS Sync settings, it's still off

Go figure


Maybe it's just me not reading the log correctly...

The rule says, if Mode becomes Night and any are home, set Ring to Home, yet the log says Night Mode(T), we are home (T) TRUE, set to disarm... skipped. Now I am officially confused, the alarm did get set to home

Sure hope to one day understand at least some of this, just when I think I'm getting it... something else eludes me

You're reading the log from top to bottom, you have to read the log from bottom to top. Look at the times that the events are occurring . The newest are at the top, oldest at the bottom.

Ryan, I am aware to read from bottom up

Look at Else-If (Mode is night(T) and Rick, Tammy any present(T) (TRUE) THEN setMode(Disarmed) on Ring Alarm Hub (skipped)

Everything in that Else-If is true yet setMode is Disarm when the rule is clearly setMode - Home


You might try IF and End IF for each mode change, rather than Else IF.

I looks to me like it should work as you’ve written it, I I understand that it did work as expected at first, but I’ve had problems myself with ELSE IF not working as I expect.

I don’t know about your feelings, but I just want things to work consistently. I don’t actually care how I get there or if it’s technically incorrect or bothers someone else. It’s my hub, not theirs. :stuck_out_tongue_winking_eye:

1 Like

You're still reading it in the wrong direction..

This evaluates first:


So, this happens next.


Then this:


Then this:

The correct action is firing. I'm not understanding what you aren't seeing.

Do you really think that such a fundamental aspect of Rule Machine would be wrong for this long and not be caught?

That is NOT the order that those two things have taken place. They are on separate lines in the log. Read from the bottom up. The skipping is taking place before the evaluation of the else-if condition.

1 Like

TY Ryan, I see it now that you have broken it down. My mistake was reading the action below the Else-If rather than just above it, to your point, reader from the bottom up

Sorry for the mistake

Sorry for resurrecting an old thread...How did you create the 'setMode on Ring Alarm Hub? did you have to create a variable (still learning)


Here is where you will find that setting.

1 Like

Thank you!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.