RM 2.1.4 Variable Issue with Add Number


Appears to be an issue with RM 2.1.4 involving "add number".

I tried both a decimal variable and a number variable with different results

  1. Neither will allow a negative value to be input
  2. A decimal variable "add number" appears to append the value to the existing value 120 "add number" 10 becomes 120.10 rather than 130.
  3. A number variable "add number" appears to work but only with positive numbers.

Odd, will look into it.

We introduced a bug when we fixed something else in the UI. So entering a negative number is what is broken. Beyond that, the arithmetic for both works as expected, including decimal values. It also appears that you can't enter a decimal point.

When I tired add a number to a decimal I got results like this:

Every time I added 10 the value resulted in:

Starting value 10.0
First add number 10 = 10.10
Second add number 10 = 10.1010
Third add number 10 = 10.101010
and so on...

The "number" variable increased in value as expected rather than appending

Show the rule. I'm not getting that at all.

I rolled back to as I have several rules that use "add number". I'll wait for the fix and retry to see if it's resolved.


Same results on current build, except now that I can enter a negative value I get an appended -10 even instead of math. This is using a "number' based GV with a "number" connector. Same test with GV without a connector works as expected (math works). Issue seems to be caused by adding the connector to the GV, even after I remove the connector the math on the variable value no longer works (just appends the value).

Yep, that's a bug with using a Variable connector with a Number. Will look into it. Use a dimmer or volume instead and it works as expected.

FYI It does the same thing with a decimal variable connector, I'm not sure if a dimmer or volume would work for my application, aren't they limited to a range of 0 to 100?

Yes, they are. Will get this fixed in next release.

1 Like

This is fixed in latest hot fix release:

1 Like

Ok, that fixed the math on the GV (with variable connector), but now I'm not seeing the value of the variable updating on the dashboard?


OK, that's odd. The change had nothing to do with that. But, I'll check it out...

I can change the value from the dashboard, but it doesn't update on the dashboard if the value is changed from RM.

I believe this was also the case before the hotfix but I couldn't confirm since it wasn't doing the math correctly.

I found the bug. Will put out a release in a bit.

1 Like

Hot fix released.

1 Like

Still not updating, tried a new GV and connector same results.

Great. Well, I'll take this up again tomorrow.

Not sure if this helps, but updating the value of the variable from the GV add/modify screen does properly update the GV connector in the dashboard.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.