Ring Keypad v2 - Buttons are not Arming or Disarming device

Driver: Not using 3rd party - standard included driver.

I am able to arm and disarm using the UI and can see the corresponding buttons light up in the keypad, but the keypad buttons does not arm or disarm device/hubitat.

I added keypad using Zwave Smart Start. Device paired just fine.

Under Apps: Installed lock code manager and set up my 4 digit lock code.
Then I went into the device page and I can see my code is updated. I clicked arm/disarm buttons in HE UI and they successfully triggered the corresponding options in the device.

I then went into HSM, and added the keypad to " Use keypad(s) to arm/disarm"

Not sure what else to do now. The device responds to commands from UI, but not the other way around.

I enter the 4 digit code I set and press on arm/disarm button on the keypad and nothing happens. Nothing shows up on the logs either when I press buttons on the keypad.

Please help!

It could be a partial pairing. Remove it from HE, fo a factory reset on the keypad and try pairing it again.

You may also want to disable the proximity sensor in the settings as that has been know. To cause issues on some of the new devices.

thank you. I did reset and repair device a couple of times. Where can I see the option to disable proximity sensor?


That is just a config option on the device in HE. Wait, you are using the built in Driver it may not have that option.

You should see activity on every key button press. That includes each number in the code. If you are not, it isn't talking to the hub from the keypad. You may want to try the community driver. I use a modified version of the community driver. On newer versions of the keypad leaving the proximity sensor on can cause the keypad to log and stop talking back to the hub.

nothing in the logs when I press buttons on keypad. I am using C8 device.

I even tried the driver at https://raw.githubusercontent.com/HubitatCommunity/hubitat_ring_integration/master/src/drivers/ring-virtual-keypad.groovy

But same result.. Even this driver didnt give me an option to disable proximity sensor. Is this the same driver you are using?

I think that driver is the built in driver provided by @bcopeland for the community to build on.

Try this one. This is the one I modified a while back. Some folks don't like it because it requires something like HSM to change it's states. I can just assure you it works as I use it every day.


thanks. unfortunately even with your drivers, only one way communication(from HE to keypad) is working.

did you reset the keypad

not before I switched drivers.. but I had reset the keypad twice today before that.

Try resetting it and adding it.. Very first thing after that change it to the custom driver and disable the proximity sensor. Then try to use it and see if that makes a difference

I agree with @mavrrick58 - these Ring keypads are a PITA to get paired correctly - but mine have been rock solid since I got them in. Some folks claim better success with SmartStart - I personally used the old-school pairing and typed in the DSK for S2 encryption (required for these to operate correctly). But what you're describing is the effect of an incomplete pair, only 1-way comms from Hub to Keypad.

As far as zwave pairing, the driver doesn't make much difference - but for sure the prox sensor can be chatty on your mesh.

That did it! Followed exactly as @mavrrick58 suggested and could immediately see the key presses showing up in logs. Thanks a lot for your help and the driver.

@dkilgore90 thanks for the info that this was a result of incomplete pairing.