Ring Keypad HSM

I had to soft reset and restored my hub to a cloud back up from about a week ago (Ring keyboard was function properly when this backup was created). Everything seems to be working fine now except the ring keypad is longer arming and disarming HSM when a correct pin is entered. I have a C8 and it is updated to the current firmware.

I had this issue months and months ago when I first set it up, (no clue how I ended up getting it fixed) but it has been working perfectly for the last few months, until I had to do the restore. When I type in a pin the keypad doesn't do anything. The keypad is less then 10 feet from the hub, and I only have 4 z wave devices. (attached a pic of the z-wave details page as well)

-In HSM I click arm away and the keypad announces entry delay started
-In HSM I click disarm and the keypad announces disarmed
-In the device settings I can click arm away and the keypad says entry delay started and is recognized in HSM
-In the device settings I can click disarm and the keypad says disarmed and is recognized in HSM

I am showing some errors in the log, and I have attached a picture of the error messages. I have tried the regular device driver as well as the community device driver and they are both functioning exact the same (as described above)

So, I thought I excluded the keypad and factory reset it. And then used smart start to readd it. I have no ghost zwave devices. I attached a screen shot of zwave details after re adding the device. Still cannot get it to work with codes. I think last time I did this I had to reset my entire zwave system and start from scratch., I'm hoping for a different solution at this point. lol

This isn't very helpful, but FWIW I'm having the exact same problem with a Ring Keypad (G2) and a C-7 - after a soft reset and restore (and subsequent unpairing and repairing to try to sort the keypad out), everything's working except arming/disarming with a PIN.

Not sure if this is relevant at all, but one thing I am seeing is a double entry for the keypad in Lock Code Manager:


There's definitely only the one instance of the keypad in Devices and Z-Wave Settings, and only one entry shows up in the actual dropdown for device selection. I've tried uninstalling and reinstalling LCM, and its individual entries, and that's made no difference. I didn't notice whether things were displaying like this before the soft reset.

Will keep an eye on this thread, and my fingers crossed for a solution.

So, I decided to just wipe my zwave network completely and start over. That is what I did the first time and got it to work. So I reset the zwave network. Factory reset all the devices. And then went into smart start and scanned the qr code for the ring keypad gen2. and according to smart start it added. But the device is no where to be found in my zwave settings or my device list.

I don't know if this would help, but there is a custom driver for the G2 Ring Keypad. It's got some extra functionality too. Maybe the driver might help. @jkister made it and works great for me.