RIng Keypad Gen 2 Does not recognize key entry (one-way communication only)

Hardware: C-7
Platform Version: 2.3.1.142 ( also 2.3.1.137)

I have two Ring gen2 keypads. Both have stopped accepting entries using either the standard Ring Gen2 driver or the Ring Gen2 community driver. However to be fair I have been slowly implementing them so I am not sure when this started although I do know it was having the same issue on 2.3.1.137.

It did work previously, although I had never implemented any advanced features available in the Community Driver.

I can control the mode via the device page on hubitat and it responds. But know keypad entries (or Motion etc..) register to the hub.

I haven't reset them as I am trying to figure out how to exclude them properly and I cannot seem to figure that out either.

Thank you

Mike

I may have read part of your question wrong so forgive me.

If you open a live log and start punching in numbers, does that register in the logs?

No. I cannot get it to receive any information from the keypad to the hub. I can however control the keypad from the hub.

Try this. Pull the batteries on keypad. Shut down the hub and unplug power at the wall (not the hub) for 5 mins. Power back up the keypad, power back on the hub and see how it is.

When you are trying to use it do you see the red wireless symbol light up?

I know my keypad occasionally does that. If you just press and dont hold the reset button done on the back of the keypad it will restart it and hopefully it will reconnect cleanly.

If not you will need to just hold that button in for 20 seconds to reset they keypad. Then go into hubitat and do a force remove.

You cant pull the batteries they are sealed in the unit.

1 Like

Ahh then perhaps just hit the restart button after the hub is powered down. I didn't realized it was a sealed battery. Trying to get his z-wave radio cleared to eliminate that possibility

I got it working. It did require a hub shutdown for 5 min and a press and hold of the reset button. It did not require a factory reset however. Thank you!.

1 Like

Did you update the zwave radio firmware yet. I will say that has also helped my keypad not have similar issues.

For a while mine required me to hit the reset button after the hub went through a restart. For me this was normally around the time when firmware updates were released. The newest zwave firmware update seems to have made this more resilient for me.

I got to where i would just do a quick check it after any restart.

1 Like

For the record, soft reset isn't a factory reset. It's a way to fix the database. (Radios are not disturbed)

Glad you got it working! What's your z-wave details page look like? Also update your z-wave firmware like @mavrrick58 recommends.

Upgraded the Z-Wave firmware. Thank you. Zwave details look good to me. No ghosts etc...

1 Like

I’m very perplexed. I have not been able to get my ring keypad gen 2 to accept entries. The device page in HE controls the keypad (arm, disarm ect) but the keypad does not seem to send anything.
I have factory reset multiple times and re joined. Completely lost here.

When you enable debug in the driver and put in a code and press a arm hone does anything show up in the live logging?

1 Like

This happen to me when using regular inclusion. Using smart start instead made it work.

I have indeed joined using the smart start. In fact, I did this out of the box. I have down this almost two dozen different times with the same result. Perhaps I’m misunderstanding the the smart start?

  1. Open Hubitat app.

  2. Select tools on the bottom right.

  3. Select Z-wave tools

  4. Click SmartStart

  5. Clicks the QR code in the upper right.

  6. Scan QR code on back of keypad.
    (This is where I would except the device to “smart start” and connect? But, it doesn’t do anything. I have waited as long as 10 minutes for it to add to the hub and it doesn’t so I continue on. Additionally, I’ve noted at times, the dev e is duplicated after I scan it, random number of times sometimes 2 duplicates, sometime 6, sometimes 3…)

  7. Click the back arrow in the upper left

  8. Click connect to hub

  9. Click devices

  10. Click add device

  11. Click z-wave

  12. Clicked z-wave inclusion

  13. When found, click join with S2 security.

  14. Wait for bootstrap

  15. Name device and add to room.

This creates the device and then it remains one way function only.

What’s wrong here? I am using the HE C-7

I assume you are resetting the device and remove the gosts between your attempts.

I only use smartstart once and it was for that specific device, so I can't realy confirm the steps you are taking but it seems odd that you have to go back after the scan. I maybe wrong but I suspect the steps 8 and next are setting a regular inclusion (not smartstart).

Maybe someone with a better knowlege of the process could confirm.

In most cases were i habe had SmartStart work properly all i had to do once i scanned the code was pull the battery tab. If you are then initiating a inclusion feom the add decice screen that is indeed doing a traditional inclusion.

I dont think that should make much of a difference though.

Download the Hubitat app