Ring Keypad Gen 1 - Cannot set Armed Home

First of all, what an amazing community, I've used so many resources on this forum to move over from Smartthings (200 devices) and ditch webcore. Hubitat is just a dream, definitely never going back to Smartthings!

I've read a lot of posts about Ring Keypad but couldn't see anyone with the same problem as me? I have a setup the Keypad using the stock Gen1 driver but I cannot get HSM to armed it in Armed Home mode.

If I use the keypad nothing happens but the logs show this:

2021-01-19 09:56:36.365 pm [error]device/edit/635)java.lang.NullPointerException: Cannot get property 'partialFunction' on null object (parse)

If I set Home/Armed through HSM then the Keypad with Home/Arm button will light up and the voice message will say Home/Armed and the logs give me the same error.

I'm not sure how to get this function working? I have integrated the Keypad into HSM multiple times, excluded and included from my C7 and hard reset using the pin hole and key 5? Does anyone have any other suggestions? Lock Manager didn't make a difference either?

Thanks in advance.

There is a major update to this driver coming in 2.2.5 which should fix you up

Brilliant - thank you for the speedy response. I can lose days to trying to get the smallest thing working. Just out of interest when is the update due?

:man_shrugging: It’s in beta now..

I had exactly the same issue with my Ring Keypad G1 ("cannot set Armed Home"). I've upgraded today to 2.2.5 and the issue became worse and now affects all states, ie "home" and "away". I can still set them through HSM but nothing happens if I use the keypad (if it helps just to let you know that I can see that the pin code is correctly received by C7). Just downgraded to previous driver.

Yes, I have the same problem. Definitely got worse. How did you downgrade to the previous driver? Sorry complete noob here.

Use hubitat:8081 to rollback to previous versions

Thank you - another new thing I learn today!

I've just upgraded to 2.2.5.124 and Ring Keypad gen 1 is still having issues.

I can now use the keypad to disarm if the state was originally set to "Armed Away" or "Armed Home" using HSM.

However, I can't use the keypad to arm (either away or home). Looking at the logs,

image

When I try to set the exitDelay/entryDelay to any number through the device settings, I get the following errors

I'm guessing if I could manage to set the exitDelay/entryDelay, the problem will be solved. Am I missing something?

Do you have the keypad setup in HSM?


1 Like

Seems that my problem with the Ring keypad G2 is similar to what I am experiencing: Ring G2 Keypad - Cannot Set property

I have my Ring Keypad G2 setup in HSM.

Keypad is registered with HSM and works ok with 2.2.4 (all interactions between keypad and HSM were ok apart from "arm home")

Under 2.2.5 I can use keypad to disarm but not to arm.

These are the steps I follow to reproduce the issue:

In HSM I have set all delays to 5s.

image

First I use the dashboard to arm away. After 5s, both dashboard and keypad (light+audio) show "armed away".

Then I use the keypad to disarm. Success! Both dashboard and keypad (light+audio) show "disarmed".

Now I attempt to arm away using the keypad. Nothing happens.

I attach the log below

(Maybe I was getting the same errors in log with 2.2.4 but at least keypad was arming/disarming ok. If needed, I could downgrade and get the new logs for the same operation)

It seems to me that the process fails because it can't get a valid "exitDelay" value and unfortunately when I go to the device settings I can't set a numerical value using the "Set Entry/Exit Delay" function.

image

image

I see that the issue that affects Ring Keypad Gen 1 has been reported in the following thread too:

1 Like

Yes, I didn't see your post. When I searched the post with issue for 2nd gen came up, and I just replied to that.
I have rolled back to 2.2.4 until a fix for 1st gen have been released. I have no problems arming with 2.2.4.

For reference there must be something specific in your environment or specific config settings causing issues. I have a g1 keypad and it is functioning without issue.

Can someone having this issue on the current hub software please enable debug logging and try this action, as I am not able to reproduce this problem.

This is what I get when I attempt to arm:

Ok.. Can you also screenshot the HSM config where you have the keypad programmed?

Download the Hubitat app