Ring keypad G2

I just bought a new Ring keypad G2 because hubitat says it is supported. I can "include" it fine, and all seemed ok, until I added it to my HSM with my other keypads. I noticed it will report the correct HSM arm/disarmed state, but i can control NOTHING with it. I look at the event logs for the device and the debug logs and see no activity when codes or anything is entered at the keypad. I have successfully used the code/lock manager to properly set all my other keypads, and they all work (they are iris keypads). Again all the other keypads work properly. Further looking at the debug log i see an error i think occurs when the device was added.

Can anyone give me some advise on how to proceed here?

I can't remember how found how to solve the issue, which probably has more details. But the solution is to install the "Lock Code Manager" App.

There is also an issue where Armed Night does not arm the keypad so I use this rule.

I had a similar issue when I got mine. All of the ring gear is very peculiar about how the inclusion is done. Make sure you use SmartStart and dont change anything in the securiry options when doing the include.

My suggestion would be to factory reset it and add it back with SmartStart as stated above. That is what i had to do. You may also want to do the inclusion closer to the hub to ensure it completes the inclusion.

I had a heck of a time getting these guys to work, but once I did they seemed OK. As @mavrrick58 says, they're really picky about the inclusion. I'd give his suggestion a try. I dunno about night mode though. I only use home and away. I also have HSM integrated with Envisalink and my Vista 20 panel... works pretty well overall though every once in a while on of the ring keypads fails to disarm the system.

I probably did not explain well, but I of course have the "lock code manager" installed, and it seems to have nothing to to do with lock codes, I did say: "used the code/lock manager". Again, debug shows nothing when any control operation is done.

Hmmmm, are you implying i can only install this device using the "SmartStart" with my phone only? This implies I can not use the "normal" hubitat local web interface to standardly "include" the ring keypad G2 as a z-wave device? I cant believe SmartStart would do inclusion any better then the standard z-wave include? What would smartstart do better and/or different? I will try it, but i have doubts :slight_smile:

I can't explain why @mavrrick58 is right but I had exactly the same experience... of course your experience may vary!

I think this is all about being Zwave 700 and using security. Basically the ring Gen 2 devices expect certain things they would always get from their normal Ring Basestation. The C7 has all the abilities so we just need to make sure we dont prevent one of those expectations.

Allot of people dont want to use security and insist on doing inclusions from the browser. Maybe i am wrong but i seem to remember something a while back where some of the prompts don't trigger/popup on a desktop browser for some reason related to security. That with SmartStart being part of all the new inclusion methods just made that my default method to do inclusions. I would use SmartStart for any inclusion with Ring devices. I have honestly had near zero blips with zwave as long as i do that.

That may be the complete issue: good advise. I did ignore the security stuff on inclusion. I will re-include and add the keys, this may work. And if not, i will still try the SmartStart. Thanks

So, the end of this saga! Yes it is all about security for this device, not specifically the SmartStart. I tried it manuall just putting in the DSK and it worked. I also ran the "SmartStart" to to verify and it did work correctly. So my laziness to add the DSK on this caught me. I will just start using the DSK when available in the future!!!! Thanks for the help.

And for one last comment on this. I actually like this keypad. In the end, it works well. The better of the three brands i am using for sure

Download the Hubitat app