Ring Alarm automation rule - Auto Arm based on time since doors closed and locked

Hey, Just trying to see if this is the best way to do this.

I am trying to set a rule where if my 4 doors have been closed and locked for more than 20 minutes then HE will arm my security alarm.

It was not working so for now I changed it to - if my 4 doors have been closed for 20 minutes and doors are locked then HE will arm my security alarm.

I noticed that some of the "Time Since" values are not populated since they have not been triggered for more than 48 hours. Any suggestions on how to improve this?

There are many ways to do this, but I would keep the same trigger and typically use a Wait for Expression with a 20 minute duration:

This will run the action after the last device was closed for 20 minutes.

Sounds good, I am new to Hubitat could you help me create the expression, never done it before?

Is this what you mean? - changed to 15 minutes instead of 20

Yes, that is exactly it!

Thank you for your help, will test it out tomorrow!

1 Like

Just tested it, works great! Thank you!

1 Like


What is wrong with this one?
I am trying to do the following:
If All doors have been locked and all doors have been closed for 7 minutes and if the Alarm is in off state then set mode to home.

Does not work.

It looks correct, but since it doesn’t work I would try:

  1. Do you have your HSM and Ring alarm synched? If so, try arming HSM instead. (That’s how I do it.)
  2. If 1. doesn’t work, enable logging on the rule and on the Ring Virtual Alarm hub. See if this allows you to debug it, and share a screenshot if it doesn’t.

Hey, looks like after a restart is works perfectly fine. Thanks for your help

1 Like

Hey there, I am trying something new now since I just got into using modes.

The logic should be, if all doors are locked and ring mode is off (disarmed) then wait for defined time (per mode) and arm.

I created the following rule, Seems to work fine however, when the backyard door is unlocked it’s still seems to arm the alarm. Just wondering if there is something wrong with how I created the rule.

I deleted the rule and recreated it and it works as expected. Thanks

1 Like