RGBW can't set color temperature

I have had this issue for a little over a week and I thought it was something I had done (because it was working previously). When I came looking for help, I found this thread matching my exact description and I'm glad to see a fix is on the way. I too had pressed the configure button and nothing happened.

1 Like

To make it work before fixed driver arrives, go to device edit page and change "Transition time" in Preferences to anythnig else than "No selection".

Thanks for replying; I got really excited when I saw this. I tried this on both of my RGBW Gledoptos (2 different models) two different ways each. I changed the settings like you said, tried it, and got no new results on both devices. Then, I reconfigured them differently again with the same results, still :frowning:.

To confirm, I made sure none of the transition time fields were set to "no selection"

I have several Gledopto Pro and they work fine with the Advanced Zigbee RGBW Bulb driver. Mine are the GL-B-008P model.

1 Like

Did you try it with "Generic zigbee RGBW light" driver? That and transition time != no selection works for me with Glepopto GL-C-008

1 Like

That worked perfectly! Thank you so much.

Hi, I'm a glutton for punishment so I purchased a gledopto dual white and color zigbee bulb model GL-G-001P.

It default adds as an advanced zigbee CT. CT control, level, on/off/flash all work great but there's no control for color. I tried all the advanced zigbee and generic zigbee drivers and none of them would allow the RGB to work. I have the most recent platform version from a day or two ago.

I have the flood light version of this light that I assumed would use the same driver and I double checked they're configured the same and they are. Still no RGB on the GL-G-001P.

@1449smarthomeautomat When you changed to the Advanced Zigbee RGBW driver, did you hit “configure “ on the driver page?

1 Like

Ok, this worked magnificently, thank you; however, I feel like I'm missing some nuanced piece of information that I should've known. I've never noticed anything usable from this feature and normally have just seen a bunch of gobbledygook in the logs. What what the significance of pressing the configure button (besides making it work) and should I have pressed this on any other zigbee lights that I have?

I believe it sends configuration information to the bulb needed to work with the driver. It happens automatically when you join a new device, but needs to be done manually any time you change the driver.

2 Likes

How incredibly insightful. Thank you for educating me.

2 Likes

is there a solution for this, i've downloaded and installed several updates since then i it is still not working, anyone has some news on this?

You grabbed the updates, pressed configure and the CT still doesn't work? This was resolved several releases ago. Are you sure you're on the correct driver and not on the 'workaround' driver? Did you press configure after you made the driver switch?

2 Likes

I'm in latest release, im using the Advanced Zigbee RGBW driver, and i pressed configure after driver switch, also this is happening with the tasmota RGBW bulbs that i have.

Well, I'm out of ideas then. It sounds like you did all the same steps I did.

most of the posts in this thread are pretty old, so lets start over with your issue.
What specific device are you having issues with?, and what is the error log produced when you send which specific command?

1 Like

I have a Gledopto RGBW Zigbee Led strip controller, I use Advance Zigbee RGBW Bulb Driver (the one from HE, no community driver). When i try to Set Color Temperature, it sends this error:

2021-10-22 01:26:28.862 pm errorjava.lang.ArithmeticException: Division by zero on line 906 (method parse)

Now when i go into another Device, a RGBCCT light bulb flashed with tasmota, and try to set Color Temperature, it sends this error:

2021-10-22 01:34:57.179 pm errorgroovy.lang.MissingMethodException: No signature of method: user_driver_tasmota_Tasmota___Universal_Parent_385.componentSetColorTemperature() is applicable for argument types: (com.hubitat.app.DeviceWrapper, java.math.BigDecimal, null, null) values: [Foco Steren 04 Terraza Derecho, 6000, null, null] Possible solutions: componentSetColorTemperature(com.hubitat.app.DeviceWrapper, java.math.BigDecimal) on line 115 (method componentSetColorTemperature)

The reason for this error is that the Tasmota Universal parent has a definition for the 'setColorTemperature' routine with only 2 parameters. You'll need to make a slight modification to the driver code. Have a look at this thread: - Tasmota Light not working with Color Temperature

Did you try the generic rgbw bulb driver? The advanced driver will not work with every device.

I just installed a Gledopto GLS-S-007Z blub (Box saysRGB+CCT) and am having the same problem described above. I can't get the color temp to change at all. It is stuck at 6535K, which is what it started as. Likewise, under state variables it says, " * ct : {current=0, requested=0, min=0, max=0}" I have tried the Advanced Zigbee RGBW driver it landed on, the Generic Zigbee RGBW Light and also a version of that modified like tomas1 suggested. No luck in any of those until I eventually got around to setting the transition time to something. I didn't notice that on this latest iteration because that part of the device settings page changed so much... I am running the newest release of HE.

Download the Hubitat app