RGBW Bulbs no longer setting color by name

I recently update to 2.2.8 and noticed that my Basic Rules that were controlling them by setting color by name does not work any more. I can control the switch from the device page, and I can turn it off an on from apps. I don't see how to control the color by color name from the device page anymore. Only picking the color or setting the hue (0-100) or saturation (0-100).

This--hue/saturation/level--is the only way it's ever worked; some apps, like Basic Rules, provide color names for convenience (so you don't have to memorize hue values, I suppose). So, that's normal for the device page, but it's still odd that Basic Rule isn't working here.

My guess: are you physically turning the bulb on and off? If so, most brands won't send an "on" event to the hub in this case, and so it could be that your Basic Rule is never waking because it doesn't see this event. The driver may affect this some, so if a change their coincided with 2.2.8, it could explain things. In general, it's best to avoid physically cutting power to most smart bulbs, and then on the Hubitat side you could just set it to red to turn it on (a "Set Color" command will also turn a bulb on if it's off, unless you have an older driver with prestaging options enabled).

I did have these Basic Rules working as shown when I first got the hub on 2.2.7. After I updated to 2.2.8 it stopped working. I've modified the Basic Rules to explcitly turn on the light device after setting the color, and it works now. I also had a rule that set the Kelvin temp and that one stopped working too. Explicitly turning On the device after setting the color temperature fixed that one too.

I actually like this new functionality. Before when I turned off the Red light, I wanted it set back to warm white so that way if I just toggled the light on it would turn on white next time, not red, Only time I wanted it to turn Red was when I used the Red Light virtual switch. In order to do that when I turned off the red light, I would have to set the color back to white, set temp to 3000K and brightness to 100, then turn it off. Not pleasant when done in the middle of the night. Now I can turn off the red light and then set the color and intensity after it is off, so it will be good to go next time I toggle it (at least I think so, need to test).

What driver are you using for these bulbs, and what kind are they? It sounds a lot like you may have enabled the "Enable color prestaging" preference found in some bulb drivers, which works exactly as you say (a "Set Color" or "Set Color Temperature" command will not turn them on; they will require an explicit "On" command afterwards but will turn on to this color/CT, whereas conventional behavior is for a "Set Color" or "Set Color Temperature" command to also turn the bulb on if it is off).

If that doesn't explain it, try hitting "Configure" on the device page to see if that helps, particularly if you've switched drivers lately (but it can't hurt regardless).

I believe they are OSRAM Lightify RGBW Zigbee smart bulbs. The driver is Generic ZigBee RGBW Light. I have not changed drivers and don't think I have changed settings. Just updated Hub firmware.

Just noticed that Color Pre-Staged is enabled.

That explains the difference, then.