RGBgenie ZB-5121 - only two buttons showing in driver

I just purchased the RGBgenie ZB-5121 to control a dimmer. After pairing it to my hub and selecting the ZB-512x driver, the Hubitat device page shows that the device has only two buttons, rather than the five it actually has. Suggestions? (I am a Hubitat newbie, so doubtless I'm missing something obvious.) Thanks!

1 Like

Mine just worked.

I suspect it didn't pair correctly. I would have thought that it should have selected the proper driver.

You could try to hit "configure" in the device page, hit save, and see if that fixes anything. That is the typical procedure if you switch drivers.

Thanks. I tried that but under "current states" it still says " numberOfButtons : 2"

I tried removing and re-pairing. Same result. Notably, when I pair the device Hubitat selects the RGBgenie Button Controller driver rather than the 512x driver.

Not quite sure what to tell you to try... Configure and delete/pair are the only tricks I can think of to try and fix this.

Here is what mine looks like when using that same driver and device. Maybe someone else has a suggestion?

Thanks. Are you using 512X driver?

I am corresponding with the RGBgenie support. They suggested using the mirror app to expose the buttons, but that doesn't seem to be working (yet) either.

If it doesn't show all buttons in the device page, you will not get it to work no matter what app you use. Hubitat isn't seeing this correctly for some reason.


@mike.maxwell is there anything you can think of that could cause this issue that @andrew8 is having with this RGBGenie button only showing two buttons instead of five?

perhaps configuration didn't complete, unlike most other zigbee devices these don't wake up every so often to fetch commands.
I can usually get the configuration to re-apply by pressing one of the remote buttons then right after releasing it, click configure in the driver...

1 Like

Thanks @neonturbo and @mike.maxwell. I tried Mike's technique several times (with both the 512X driver and the generic RGBGenie driver) to no avail. Also tried removing and repairng again just for kicks. I am starting to think that I got a defective remote,

I have just received my ZB-5122 and it has the same issue. The driver selected by Hubitat is the generic RGBGenie driver and shows as only having two buttons. Changing to the correct driver (ZB5122) still only shows 2 buttons.
I selected the Z-Wave ZB-5009 driver and pressed configure and save and the button count changed to 12 (correct for that device). Of course it did not work. When I then selected the correct driver (ZB-5122) the button count stayed at 12. This now allows the selection of the 5 buttons when using the Hubitat inbuilt Button Controller.
This suggests that there is an issue with the inbuilt driver for the ZB-5122 and ZB-5121.

iā€™m also having this same problem. @Gnant have any idea what could be wrong?

FWIW, I never did get the remote working. However, I've switched to Lutron Pico remotes. A bit of investment in the hub, but man the remotes are NICE. And they just work. No regrets on the investment in the hub. (Well, maybe one regret: I liked the remotes so much that I now have a bunch of Lutron dimmers in my house too.)

nice fix!

I just received my RGBgenie Controller ZB-5028 and pairing continued to fail. Hubitat showed "Found ... initializing ... but timed out with no new device found. I moved the unit closer to the Hubitat device, retried it, and it worked immediately. Hubitat now sees my RGBGenie.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.