RGBGenie Remote Delay to zwave dimmer

Hi - I'm trying to control Leviton dimmer plugs (zwave) with a RGBGenie zB-5004 (Zigbee). The dimmer plugs seem to work well with the DZ6HD driver (and also with the Any Z-Wave Dimmer driver). They respond quickly to changes via the UI.
I've tried several ways to link the plugs to the Remote - Device Mirror Plus, Switch Binding app, Link 2 Switches, and the native Rule Machine dimmer tracking. The latter seems to be the best in terms of minimizing delays - but there are still lags at times in responding to the remote.
I have both Z-wave repeaters and zigbee repeaters (plugs) scattered throughout the house, so I don't think that's the issue.
Is there anything one can change to optimize the response time? Or any way to look for the source of lags?
It would be great to link the remote directly to the plugs, but I've yet to find decent z-wave remotes or zigbee dimmer plugs - so I seem to be stuck with a modality change handled by the hub.
Michael

Being battery powered, these remotes are sleepy devices. Sometimes, it takes a second or two to "wake up" before transmitting zigbee packets.

I haven't found a zigbee or z-wave remote that doesn't suffer from this issue.

Would this apply even after you'd used it? In other words, I'll turn a light on, it will respond. Then I'll try to dim it and I'll get a lag. Would you expect them to fall asleep that quickly?

No. I only see the lag in my first action after a break of 30-40 minutes. I use the built-in
"Mirror" app with mine.

So that is he primary "connection" between the remote and the target device - ie Device Mirror? That was what I tried originally but the delays were longer than I seem to be getting with RM Dimmer Tracking. (To be specific, I tried Device Mirror Plus - not the native Device Mirror)

The app I use is called "Mirror".

Just tried this - no better. I'm definitely getting intermittent lags - or no response at all. Might there be some other issue in the zwave communication with these particular Leviton modules? Not sure how to diagnose this - but they seem to respond fine to the driver UI - so I assume the problem is translating zigbee commands from remote to z-wave commands to the dimmer plug driver.

Download the Hubitat app