Restoring Z-wave devices to a replacement hub

I have a C-7 with a corrupted database that won't boot. I am unable to reset it and email support just stopped responding after I exhausted their suggestions. Anyhow, I do have a backup file from the hub and I would like to know if there is a way to somehow migrate to the replacement hub without having to reset and re-include all of my z-wave devices. I understand that Hubitat has some paid cloud service that supports this function but I wasn't subscribed so I'm not sure if I can still take advantage of that now or if I even need it to accomplish this. I haven't tried restoring the backup yet because I want to get some guidance so as to avoid wasting time. Thanks

Curious how you came to that conclusion. Did support tell you that? Maybe @bobbyD can help here?

What did they have you try? Can you summarize their suggestions?

I would see if we somehow could get the old hub up and running, but it will help to know what you and support tried first. A corrupted database shouldn't in most cases be a permanent failure.

Yes, but no. Zwave radio information doesn't transfer in those backups, so there is nothing automatic. But your automations, dashboards, and so on would still be in those backups. So you could do a replace of the Zwave devices so you wouldn't have to start completely over. There are a couple types of replace. In Zwave, you can do a replace of a failed device for another. I think in your case this would work, you would reset the device, and it should pop right back into the old Zwave slot as a what the new hub would see as a "new" device. There is also a new replace device function in the latest Hubitat firmware that also can replace most devices 1:1.

This won't work for your use case. You had to have previously subscribed so it would upload a cloud based backup. But that is gone.


After resetting the hub from the diagnostic page it reboots but still hangs on 10% initializing. Support wanted me to unplug the hub for a few minutes and try again-- no luck. They told me my case was referred to engineering but I haven't heard from anyone.

I've reset this hub a couple of times already for a corrupted database. Seems to keep happening until this last time when it wouldn't boot. I suspect that there is some issue with a bad sector in the memory.

Has anybody tried transferring the radio between hubs by desoldering and soldering? Seems like less work than trying to reset and re-include 20 contact and motion sensors.

Can you be more specific about "wouldn't boot"? What do the LED on the box do? Does the interface do nothing, or does it stick at some menu or message? Are you able to or have you tried to access the :8081 diagnostic menu?

I doubt it would work, and it is so tiny it would be real easy to mess up. That would probably be the last resort if it even would work at all.

1 Like

Again, I've done this before and have installed and programmed many Hubitat hubs. I'm resetting from the diagnostic page, entering the MAC but when it reboots it hangs at 10% initializing and sits like that for days. All the while the LED in blue.

I'm at the last resort. For me saving the 3 hours resetting up the devices is worth the $100 I might lose if I screw it up.

If you can send me the ticket number, I'd be glad to check on the status for you. Or better yet, send me a PM with your hub's MAC address (there is a sticker on the hub itself). I doubt that taking the hubs apart would save you any time, and likely, you'd end up with both hubs out of warranty and needing a third hub.


I PMed you a few days ago.

Like I said originally Hubitat support just stops responding when they don't have solution. This has happened twice already.

1 Like

Please check your PM. We will need additional details.