RESOLVED: zwaveCrashed Quite a Bit

I recently picked up a Hubitat Elevation C7 and have been setting up my network (all Z-Wave). Unfortunately, it seems my hub has a tendency to crash the Z-Wave network/radio and requires a reboot to fix it. When I look at the logs, I can see that the hub is logging this event. What's interesting about the logs is that Z-Wave seems to crash only at the top or bottom of the hour, at very precise times. Has anyone seen anything like this?

Name Description Value Event Type Date
zwaveCrashed Z-Wave is unresposive zwaveCrashed SYSTEM 2021-08-14 01:00:00.035 AM PDT
zwaveCrashed Z-Wave is unresposive zwaveCrashed SYSTEM 2021-08-13 11:30:00.034 AM PDT
zwaveCrashed Z-Wave is unresposive zwaveCrashed SYSTEM 2021-08-10 05:30:00.034 AM PDT

I assume there is something significant about some process the hub runs at the top and/or bottom of the hour given when all these crashes are occurring, but specifically which hour the crash happens is variable. Does anyone have any ideas?

Could you post a screenshot of the logs (the table above indicates the System Events)? Also, a screenshot of your z-wave details page (it is under Settings).

Tagging @bobbyD to give your community account permission to post pictures.

1 Like

It looks like my logs only go back to earlier this afternoon. I stop getting a "show more" message before I can get to the most recent crash (1am this morning). These are my Z-Wave devices. I probably didn't mention it before, but I also have Zigbee totally disabled since I'm not using it.


I guess I'll have to wait to see if Z-Wave crashes again in order to pull the full logs. I can say that no human-triggered activity is happening at the times of these crashes, and no user-configured automation rules are running either, because I don't have any. The only thing I have done that goes beyond vanilla Z-Wave configuration is to link my Google Home to Hubitat in order to use voice commands (which I wasn't using at the times of these crashes).

Can you post a copy of your z-wave details page?

They did above, it just was not linked correctly.

It seems odd that there is no routes, and no RSSI on ALL the repeaters. I would say that those need some investigation. Maybe I am not used to this updated menu yet, or maybe because I am not fully awake, these first few items almost look like a ghost, but not quite as it doesn't say "Discover" in the 3rd column.


1 Like

I agree, likely a ghost (37) 2 things could happen though. He could hit refresh till REMOVE shows up, or I had experienced this trying to add a zooz sensor through a stick, it would do nothing until the device was powered down (not just not allow remove but also not show the actual remove button)

1 Like

Question are you using the mesh setup ? Option to refresh every hour , maybe that could be it ?

When the message for the zwave is logged can you see anything in the zwave section ? As in are all devices still shown.

I'm not sure what you mean by "mesh setup." I only have a single hub, and if you're referring to use of the "Hub Mesh Enabled" setting on my devices, the answer is no. I do not have that enabled.

All my Aeotec devices are set to their default settings, which for the switches means reporting watts, volts, and kwh every 10 minutes.

I don't know why no route was shown for the extenders earlier, but they are showing a route now even though my Z-Wave radio has crashed yet again. This time it crashed at precisely 9am this morning (Pacific Time). My logs appear to have stopped for some reason at 8:45am, so there are no logs for the 15 minutes between 8:45am and 9am (or afterward as I haven't restarted the hub yet). I don't know what to make of that. To me, the logs don't look out of the ordinary. I don't see anything that's clearly an error message. However, the System Events does show the 9am Z-Wave crash (and I got a notification in the hub notification area). I'll see if I'm able to attach screenshots yet...

(answer: nope, so I'm going to give you another intentionally malformed URL to correct)


I don't believe I have any "ghost" devices, though earlier I did try setting up a bunch of Zooz plugs, which were awful in many ways (signal strength, disconnecting randomly, and general hardware failures). I removed them all from the network...I think following the proper procedure...and returned them. They don't show up on the hub anymore. Anyway, I'm thinking that my next logical step it to attempt a full reset, which will be a PITA. Any other thoughts?

Sorry I meant hub mesh, I thought maybe it was updating every hour which might be cussing the crash.

I see you are using mostly Aeotec devices which is the same as myself however I’m not using S2 secure connections. I can’t be sure but I believe using S2 security adds an extra load on the hub giving little benefit (maybe someone else can confirm ?) have you tried just using standard inclusions and maybe only use S2 for locks ?

I haven't tried connecting without the S2 security, but that is an interesting thing to consider. I'm not particularly worried about security of my switches, but it's always nice to have. My smart lock and other security stuff isn't going through my Hubitat anyway. I think my next step is going to be to try a factory reset. I assume that if I do that, it would help to exclude all my current devices before resetting?

I suggest you contact support, including a link to this thread, before doing anything else.


Full reset is a last nuclear option. Re post your current z-wave table. Good getting rid of the zooz plugs. They're heavy reporting and a pain to deal with. Also the zooz 4-in-1 shouldn't be used either unless paired with no security with a z-wave stick set up as a secondary controller. As to security, I would leave it off except for locks and garage openers. s2 is generally fine but has overhead, s0 is horrible and should be avoided when possible.

One thing when all is said and done (confirming your z-wave table and what not) Download a fresh backup to your PC. Do a soft reset and then restore the backup you downloaded to your PC. This will ensure you don't have a corrupt database causing all your issues.


FYI, I worked this issue through Hubitat support and ended up getting a replacement hub. They had me upgrade firmware and I later excluded, soft-reset, and rebuilt my network without any S2 and the Z-Wave radio was still crashing.

The new hub has now been set up with my network for about a day and no crashes so far. Everything is working great. It looks like this was just a case of defective hardware! Thanks for the help, everyone.


Glad you're settled! Just remember, everytime you have a failed pairing it will likely create a ghost. Stop what you are doing and get rid of the ghost

1 Like

2 posts were split to a new topic: Z-Wave Crashing on C-7 after updating to latest release

Thank you; I have three messages into support but no response so far from them. It's been 22 hours.

Support has responded (see thread linked below). The issue is being looked at by Hubitat engineers ....

1 Like