[Resolved] zwave melt down

I tried the upgrade when it came out and then upgraded to when it came out. After 156 I noticed some of my simple motion and mode lighting apps stopped working or produced inconsistent results. I checked the zwave details page, to find about half of my zwave devices listed as FAILED, including the ones in question. I quickly downgraded to but that did not solve the problem. I then downgraded again to and did a database restore from the same version (something I failed to do with the downgrade). While some of the sensors are still showing up as FAILED some do appear to be working.

Something is seriously amiss, though I am not sure where. My zwave mesh has been pretty healthy but honestly I didnt check it after the upgrade but my devices were still working.


Ack, I'm on 148 and don't think I'll be upgrading until I hear from people that these things are ironed out for the most part. Or unless they tell me that they're fixed and such.

1 Like

This actually is more cosmetic than a real failure. Two things: if you use those "failed" devices, they will switch from failed to OK when you refresh the Z-Wave page. Also, if you hit refresh for one of those failed devices on the Z-Wave page, it will change to OK. There's an issue with how this "failed" state is determined wrt the display of that page after update.

1 Like

My experience with was nearly the opposite.

For the first time with 2.2.4, all devices (including battery powered and disconnected devices) showed OK after the update and were very responsive when sending commands from dashboards. Even after network wide repair, the device that is unplugged (and failed repair) showed OK status. (For fun I did refresh action on this device from zwave details page and it went to FAILED status, as expected.)

1 Like

Sorry to hear about your issues.

The FAILED notifications on the Z-Wave details page are normal/not a concern for battery powered devices, those should always be ignored unless you actually find one of those devices not reporting (which is rare).

For mains powered devices (switches, plugs, etc.) that show FAILED, leaving them sit or using the Refresh button can bring them back to OK status.

Regarding the firmware update to .156, the release notes indicate a reboot after applying an update may be required:

** Please note that a hub reboot may be required after update - Settings >> Hub Reboot **

A reboot and waiting a bit may have resolved your initial issues after the update.

The next time you run into something like this I suggest you post what's going on here and folks may be able to help you work it out w/out you jumping through hoops and multiple downgrades/restores.

If you're feeling brave, you could take a backup and re-try the update to .156, do a reboot after if you see things looking off/automations not working and let things sit for a bit. Of course, I could easily understand why you wouldn't want to trust it again, and if things are working for you, then there may be no reason for you to update to However, there are some significant Z-Wave improvements in .156 that should provide a better experience for you overall. For me, using .156 is the fastest I've seen my automations run.

1 Like

Thanks for your input. The FAILED status does not seem to be merely cosmetic. Some of the devices were working fine before the upgrade and they stopped reporting afterward. In fact that's precisely how I noticed the issue. One or two of them still aren't working this morning.

While I appreciate your suggestion to post and wait for a reply before immediately jumping through hoops, I don't think that's a fair characterization. I read the release notes.I tried a number of steps to recover, including powering down the HE for a few minutes and start it back up, then waiting a while to see if it recovered. None of that helped. In fact there are quite a few people who have posted issues about the upgrade having same issues and having them resolved by restoring to I read through those and, facing a whole bunch of home automation that was broken, I downgraded. In fact the downgrade did resolve a lot of issues though one or two devices are still non-responsive.

I think the real lesson for me, and I don't know why I haven't learned it before, is don't jump on the latest upgrade. Wait a week, read through the forum to see what the real risk is, see if it actually addresses issues I'm having, and then make a more calculated decision to move forward. I think it may also be worth my effort to invest in building out a lower environment. If I had an acceptance region and could figure out a way to do some regression testing on my own (or at least smoke testing) before pushing upgrades into production that might be a safer path.

Here's a suggestion for the HE folks... the release notes that are published in the community forum are different than the release notes displayed when you go to download the update from the HE console. As an example, the comment above about a reboot may be required only appears in the community forum version of the release notes, not the ones displayed on the HE console when you go to do the upgrade,

Thanks for your suggestion about taking a backup and trying the update again. I think the reversion to .148 has stabilized my z-wave issues and I'll give it a shot.

Unfortunately that was not my experience. I tried refreshing the failed devices several times and they never displayed OK. Several of the devices that reported FAILED had also stopped responding, though some seemed to be working ok.

Update from this morning: I still had some non responsive devices so I removed and re-added them and they seem to be back up and running. After a cup of coffee to stabilize my nerves I have attempted the upgrade to .156 again and it seems to be OK. I did still see a few FAILED zwave devices but this time (as opposed to last time) clicking REFRESH did indeed resolve what now appears as a cosmetic issue.

My best guess is that I had the issues in .153 and didn't notice, did the upgrade to .156 and the issues did not go away. Reverting to .148 resolved almost all of them, re-pairing those sensors and then upgrading to .156 seems to have left me in a relatively good spot.


This might be unrelated to zwave and actually related to this Strange behaviour in motion lighting app since fw upgrade

Could be but I definitely noticed some of the zwave motion sensors involved were not reporting.

Glad you have things in working order (mostly, I believe) again. :slight_smile:

Thanks for adding this info - your original post, understandable as it was likely written when you weren't exactly relaxed, didn't include this. I hope I didn't come across as "lecturing" or anything, just wanted to help. Apologies if I sounded too "bossy pants." :slight_smile:

I'm afraid that I have simply given up on pretending that I have the will power to do that. My process is at least now semi-reckless:

  1. Take a backup
  2. Do the upgrade even if everyone who's done it so far says that it burned down their house and turned their families into zombies. 'Cause I'm special and I'll be OK.

LOL thanks yes my original post was not written with my normal clarity :slight_smile: I am basically back up and fully functional on I did end up having to exclude and re-include a couple of devices but far fewer than I was fearing. Thanks for all your assistance.


You, you...bossy pants!




1 Like

I have experienced the same problems as the OP, and have used the same resolution as you stated. Is there any hope that a future update will fix this so that after an update, it automatically takes care of this so that we don't think the upgrade has caused problems?