Reset Nanoleaf

Not sure where else to post this. I use the built-in Nanoleaf Aurora driver to control a Nanoleaf Shapes install in my house. After a recent incident, my Nanoleaf controller was damaged and had to be replaced. When I got the new one set up, I went to try and grab a new authorization token for the existing device and found that it wouldn't request a new token since it already had one and I could not find a way to clear the existing one out as it is stored in the device state.

I ended up having to create a whole new Nanoleaf device and then update everything that referenced it. It would be really helpful if you could just reset the existing device and get a new token instead of having to go through the process of creating a whole new device. Considering how unreliable Nanoleaf shapes have been for me as a whole, and how often I have had to factory reset it, making it so the auth token can be reset on an existing device in Hubitat just makes sense.

1 Like

Following because I have an Aurora and an Elements. Today I tried to setup what appears to be an open box canvas and I've been having mega trouble getting it to connect all day. Similar symptoms may be manifesting differently.

I did a hard reset and that worked for me. You may not be willing to do that and sacrifice any custom scenes.

I'm pretty sure when I changed my nanoleaf controller I changed the driver to a zigbee toolbox and cleared the token then changed back and then got a new token

Wish I had thought of that workaround before I manually set everything up. Still, there should really be a way to clear out a device state in Hubitat.

I used the driver in this thread to rest the token

Download the Hubitat app