Request driver for zigbee curtain switch smartlife/tuya

Hi all.

My Gf got me this... we had something like it but it was wifi... these are zigbee only.
Hubitat picks them up but doesn't know what drivers i need to use... i tried
those zemismart drivers and a few aqara switch... but it doesn't function.

so my question is, has anybody tried these... with succes? and what driver/app did you use?
Or maybe you know what to use... pls help me...

I don't need any half open/closed option, it's to fully open or fully close roller shutter... don't know if that's the right word... in my lang it is called " rolluik "

Did you hit the "configure" button on the device page after changing the drivers?

It was first seen as a temp/humid sensor from aqara.
I knew that wouldn't work.
Then I tried other drivers... Some have initializing button, other config... I don't know what one i did hit of when not... I tried a lot of buttons, before, after,... So I van't Tell... What driver are you thinking if i may ask?

I am afraid there’s no Hubitat driver for this device.

Please post from the device web page the manufacturer and the model (in the Data section at the bottom of the page)

Don't really understanding what/where you want thé more info...

Is thé device Page that my GF used to buy it.

And here is thé box it Came in.

That's all i have i guess.

I mean the information that is available from this device in HE web page :

1 Like

Ah ok, sorry.
i even included the device pairing info.
I had the device deleted and reconting so why not include that :stuck_out_tongue:
It now thinks it's a motion sensor from Xiaomi/aqara...

1 Like

I bet it's because my GF gave it to me...

maybe i should ask what would work...
I'm a all zigbee home (0 z-wave devices... for real) and this device is used to close...

think you would call them blinds? roller shutters? i don't know...

I did had a look-a-like device that was wifi based but having 10 of them clutter my wifi

1 Like

@gertjan.deprez have you checked this thread? (long read!)

BTW, your device is not paired OK to HE hub. When checking the Data section, make sure it has the EndpointId = 01 and model / manufacturer values not empty.

Try pairing it again very close to your HE hub.

yeah I did check it out, I even used the driver from this guy Zemismart curtain switch - #13 by anon61068208

meanwhile i deleted the device from the hub... stripped a cable etc and now even at a distance of 1m from the hub it's not filling in the manufacturer etc. still the same :cry:

to give a idea what drivers i already have tried... one even twice :stuck_out_tongue:

That's really weird... Is there any information ih the leaflet on how to factory reset the switch?

Do the following: change the driver to the HE inbuilt driver named 'device'. Click on the 'Get Info' button and copy/paste here the logs, hopefully, the device fingerprint will be shown and the missing data may be filled in.

Then, with the 'device' driver and the Debug logs on press each of the 3 buttons. If there are any debug logs that follow the physical button presses, please post these here.

Additional question: please confirm, that with this switch you are going to control directly the motor blinds. Do you have a wiring diagram - how the motor up/down directions are controlled? And how the upper/lower limits of the motor rotation is set?

There is no information about how to reset the thing.
It even seems that the small instruction is even more for the wifi version then the zigbee one.

once again I removed the device started all over again.
It thinks it's a motion sensor and this is the 'log' from the device when i don't change a thing...

Then I changed it to 'device' like you asked... didn't know this was even a thing :stuck_out_tongue_winking_eye:
only the part below is being added in the log... and i had to wait for a bit to even get this.

dev:15112022-08-15 13:13:01.026 errororg.codehaus.groovy.runtime.metaclass.MissingMethodExceptionNoStack: No signature of method: DefaultDevice.checkEventInterval() is applicable for argument types: () values: [] (method checkEventInterval)
dev:15112022-08-15 13:09:53.061 errororg.codehaus.groovy.runtime.metaclass.MissingMethodExceptionNoStack: No signature of method: DefaultDevice.checkPresence() is applicable for argument types: () values: [] (method checkPresence)
dev:15112022-08-15 12:13:01.064 errororg.codehaus.groovy.runtime.metaclass.MissingMethodExceptionNoStack: No signature of method: DefaultDevice.checkEventInterval() is applicable for argument types: () values: [] (method checkEventInterval)
dev:15112022-08-15 11:52:39.004 debuggetting info for unknown Zigbee device...

pushing button(s) ads... to the logs, or some like it depending on the button

dev:15112022-08-15 13:30:24.173 infoZigbee parsed:[raw:C112010102100800200000F03001, dni:C112, endpoint:01, cluster:0102, size:10, attrId:0008, encoding:20, command:0A, value:00, clusterInt:258, attrInt:8, additionalAttrs:[[value:01, encoding:30, attrId:F000, consumedBytes:4, attrInt:61440]]]

Little side note,
The device is now plugged in in a outlet and just powerd, there is no 'motor' now to move things... (i don't have blinds nearby the hub).
Previously I had it connected like this...

pushing on the buttons on the device worked perfect, blind went up, down or stopt when pussing the middle button.
Before this zigbee version I had a wifi based one, there is no limit of opening/closing... after X amout of time it auto 'stopped'.

the only 'big' difference is that the icons are a bit different and on the zigbee based one the middle button is red unless a other button is being pushed.
In that case the pussed button turns red and the rest blue.

If it is easier to direct me to a zigbee device known to work on hubitat and can be deleverd to belgium... that would do the trick.
OK... Gf would be a bit hurt since 'here device' is a 'bad' one but he... better to have something that works.

Thank you for all the information, @gertjan.deprez .
I learned something new about the Zignee curtain switches implementation in Tuya platform, Surprisingly, Tuya has documented their implementation of the Window Covering cluster (0x0101) custom attributes - here.

You should have been able to configure the blinds up and down rotation/moving limits from Tuya SmartLife app?

The blinds control will not work if the switch calibration settings are not configured, except the default timings by a chance have fit your particular motor speed. The calibration timings are between 3.0 and 900 seconds, with a resolution of 0.1 seconds. Except there is a way to calibrate the MovingUp and MovingDown timings using some key combinations, this calibration procedure must be provided in the driver. Which will make the driver rather complex.

Let's hope someone will chime in with a curtain motor switch solution that is already supported in Hubitat.

A possible workaround could be to purchase a Tuya Zigbee gateway ( 20..30 Euro) and then calibrate the motor from the Tuya SmartLife app and probably (not sure) even control the motor using the community Tuya Cloud integration in Hubitat.

Anyone else had any luck with these ?

I've tried to use the 'qs-zigbee-cp03' variant with the built in driver as well as the ST-ported 'ZigBee Window Shade' but no idea how to calibrate.
The instructions in the 'Window Covering cluster (0x0101)' are unclear to me, tried both QUICK_CALIBRATION and ACCURATE_CALIBRATION but nothing works.

Can you explain the use case with this device? I am a bit unsure how it should work with HE...

Is it supposed to control directly the ZIgbee window shade (or a group of Zigbee shades)?
Or the intended use is to create a virtual shade device in HE, and then use RM5 to sync the virtual device settings to the real shades?

Two. Months. Later.

The device itself connects directly to the shades and has UP and DOWN terminals (powers the motors opening/closing the shade).

HE should see it as Zigbee Roller Shade, it does work, but it only goes up about 20ish percent of the way, so methinks calibration is what's missing.

1 Like

What is the time duration of the up/down movement, before it stops? 10 seconds exactly?