Replaced problematic Cree bulbs with Sengled, it now takes 2-3 button presses to turn on

Had three problem-free years with Cree zigbee bulbs before 80% of them suddenly stopped working and wrecked my zigbee mesh. I replaced them with Sengled bulbs and, despite my zigbee mesh being problem-free for the last year in our new house, they aren't always responsive on the first try. They respond fine when already on, but when off for some time, it sometimes takes 2-3 button presses (or on commands in device settings) for them to turn on.

I understand the Sengled bulbs do not repeat like the Cree did -- but I have plenty of repeaters (though a few are peanut plugs). Anyone else experience something similar?

I use Lutron Pico remotes and Iris v2 motion sensors to automate Sengled color bulbs. They always work on the first try.

Which driver are you using with your Sengled Bulbs?

I just experienced some laggy lights the other day. I discussed it with BobbyD and realized (per his expert opinion) that it was actually my lightify strips causing the issue. I had changed my channel recently to make room for my smartthings hub again. Something keeps telling me that I shouldn't turn that hub back on. :grin:
Do you have any other connections that may be causing issue? Like my issue was that I changed channel to 15 and the lightifys like the higher channels. I did not know that. I would have never put that together myself. I feel your pain with Crees. they are evil.
And yah I had some blinking issues when I chose the wrong driver for the sengleds.

1 Like

I'd question my mesh if it were me. How do you know it's heathy? Have you checked routing? Do know for a fact that the Sengled bulbs route through the peanut plugs?

Check your routing (disclaimer: I use an Xbee to see my Zigbee routing and really don't know how to read this)

Shut the hub down for 30 min. The Zigbee mesh should rebuild after that. Then give it a day to settle and test again.

Yes a key with Sengled is drivers. Usually it's best to use the Generic Zigbee version. I noticed that myself sometimes the color bulbs didn't want respond correctly with the "Sengled Element color" drivers. Plus I'm not particularly a fan of the fade on/off effect.

1 Like

I learned that the hard way. I had a poltergeist in the basement one night. The lights flashing on and off for about 30 minutes. It was ... eerie, but funny. My hubs was like "your spark plugs suck!" He doesn't really get home automation. :grin:

1 Like

@april.brandt lol maybe it thought it was in a Night club :smiley:

1 Like

Well I can tell you that it wasn't standing room only.

Thank you everyone for your suggestions. I switched to the generic zigbee driver which seems to have reduced the frequency of this problem, but it still happens at least once or twice each day.

Nothing looks obvious or concerning in the Zigbee neighbor table, and all other zigbee devices work fine (just a note, this problem happens with bulbs that are less than 10 feet from the hub).

I have a simple lighting rule to control a closet light via contact sensor (this is far from the hub). It simply never responded to the door being opened and closed, so I turned the power to the bulb off and back on, and it immediately worked again. It's almost like the bulbs go into a standby mode or something.

Have you tried changing this setting with the Sengled driver? I noticed when messing with Zigbee modules I pulled from Sengled bulbs, that I wasn't getting a consistent response when the transition time was set to ASAP, but when I changed it to 500ms the response was as expected.

Screen Shot 2020-03-14 at 9.32.22 PM

1 Like

That setting only seems to change the dim rate. My problem is that lights are simply not responding at all after multiple button presses or rules firing. As soon as I physically switch a light off and back on, it immediately responds. I am starting to think this is likely a mesh issue, possibly due to the peanut plugs despite this occurring with lights that are very close to the hub.

I was trying to explain that the setting, regardless of its intended functionality, is what made the modules respond for me. Are you're saying you tried it and it didn't change the response of the lights when you tested from the driver?

By the way, make sure when you change drivers that you click the configure button too.

When you troubleshoot, always test from the device details page first. Then test from a switch, button or rule. Since you're saying the button and rules act the same, then you can likely just test from the button first. Always one at a time. Too many variables will make the problem too difficult to troubleshoot. The peanut plugs are a suspect, but they should be kept in the mix at first while you test the driver setting, and then the button. If the result is the same, then turn your attention to the peanut plugs by removing all of them, re-pair the bulbs directly to the hub, and re-test. Same order.

If in testing, if you find turning the light on or off from the device details doesn't make it respond, then it's maybe a driver issue or a mesh issue. Since many others use the same driver and lights with no problem, I would increase my suspicion level on it being a mesh issue. However if it does work from the device details page, but not from the button, then I would turn attention to the button. However, you said a rule also cannot control it, so then I would also look at maybe the rule has a problem, but only at after first testing the aforementioned. I would build a very simple rule. With the trigger being a virtual button, and the action being to toggle the light. If that works, then it's perhaps something in the button's connection to the hub or the way the original rule was built. If it doesn't, then it starts to look again like mesh. But all must be done in a very methodical order, otherwise it starts to look like witchcraft or gremlins are to blame! :stuck_out_tongue_winking_eye:

Keep logs open in a separate tab while you're testing and look for a response of the driver and the button in the logs. Turn on debug logging.

Good luck


If you look at your routing table at (replace the x’s with your hub IP address), you will see that proximity to the hub does not mean anything to the device. I have a bulb within 2 feet of the hub that is routing through a Samsung plug on the other side of the house.
Oh, and Peanut plugs will drop devices and change routes every few minutes. I replaced all of mine with Samsung and Sylvania plugs, and GE in-wall switches.

1 Like