Repeating 'lower volume' seems to fail


#1

Any tips on this one? I'm trying to fade out the Sonos but it doesn't work, am I missing something obvious?


#2

Does it lower it once on the device but not at all in HE? Or does nothing happen on either side? Try adding a "Refresh" after the lower volume. I had to do that with Google home. If it doesn't pick up the volume change then it won't lower it the next time.


#3

Refresh doesn't seem to be an action of media player?


#4

And the other questions I asked.......


#5

It doesn't lower the volume at all but it does set the volume to 50 (which I do time delayed for the next time I walk in the shower and it turns on again)


#6

Youre not going to get anything like a slow fade with this. You're going to have to have a delay between the volume settings. They are being sent so fast the device doesn't have a chance to respond so the settings are overwriting each other.


#7

I'm confused. When you issue the "Lower Volume" command it sets the volume to 50%? Or does that get set somewhere else?

Try using the adjust level or set level commands instead. It looks like the volume is tied to the dimmer level in the driver. @mike.maxwell, can you confirm?


#8

Sorry, I was saying that in another rule I set the volume to 50pc and it works, so I'm saying the device is controllable but perhaps lower volume doesn't work


#9

Volume works down to 1. I have 5 different sonos players. You're sending the commands too quickly.


#10

Ok, will add more delay...


#11

My Sonos was slow to respond when it was connected to my WiFi. I added the boost to put it on it’s own network and it dramatically sped up the responsiveness.