Repeated geofence warnings?


#1

I've installed the new mobile app. Every time I go to the Geofence tab, it pops up a warning saying "To utilize this feature, please enable geofence in your settings." However, when I go over to the Settings tab, "Enable Geofence" is already turned on. Is this expected behavior? Do I just need to push the "Do not show this message" button? Or is this indicative of a bigger problem?


#2

On my iphone I had to go to the ios settings and allow Hubitat to access location. (which I normally have off for almost everything)


#3

Please provide the following information when posting an issue or requesting support:

-Phone make and model, ex iPhone Xr
-Phone OS version, ex 12.3
-App Version, ex. 1.25 build 42
-Region or area you are in, ex, US

Also, please provide any screenshots, videos, specific steps you take and if the issue you are having is repeatable.


#4

I had the same issue tonight on iPhone XS running iOS 12.2 with the current app and firmware on the hub in the US. My phone had been updating its location for the last 24 hours or so then we went out to dinner and came home and it didn't update so i went into the app and saw the same message on the geofence page and location was off on the settings page for some reason.


#5

iPhone SE
iOS 12.2
App v1.0.3 build 42
US

It was still popping up that warning this morning. Also, the presence wasn't updating.

Then I tried going through the "Select Hub" (and select device) process in the app again. After that, the warning went away and my presence updated. So I think there's a bug if you just install the app and let it set up your device. It's not truly completing the setup process until after you manually go through the "Select Hub" process.


#6

Maybe an additional bug? I just went back into the app, and "Enable Geofence" had turned itself off in the last few minutes.

(I'm a mobile app developer myself, so I know how hard this is and how many edge cases come up from everyone's different versions of phones and operating systems. Hopefully my bug reports can help. Appreciate the work you're all doing!)


#7

Have you enabled the app for location access? I'm talking about in your iOS setting app? Not in the Hubitat app.


#8

Oh most certainly yes! That was the first thing I checked. :smiley:


#9

Did you click on Always or "only while using the app"?


#10

Always


#11

Hmmm....dunno. I only have an iPad (for work...phone is Android), so I'm not quite sure.


#12

It seems to be working now, but I had to go through the extra "Select Hub" process manually. I think the bug is in the initial setup. It's not fully setting up.


#13

Yes, I got that too. Had to force quit and go back in and set up the device manually.


#14

Unfortunately I'm back to square one. When I left the house today, I kept a dashboard open that shows all my different presence devices. The Hubitat geosensing never detected me leaving. (My HomeKit and Alexa geofencing DID detect me leaving.) Then, when I went back to the geofencing tab in the app, it popped up the warning again.

Looks like this pizza needs some more time in the oven.


#15

Has this been resolved @patrick? My geofence is not working either as a presence sensor. In fact, it moves my hub location back to default in the middle of nowhere. The app is also struggling when trying to handle 2 different hubs. It wants to go back to my first hub if I accidentally pull the screen down to refresh instead of hitting the refresh button. Then I have to log out if I want any hope of using my 2nd hub.

-Phone make and model, iPhone Xs
-Phone OS version, 12.3.1
-App Version, 1.0.4 build 48
-Region, US

I have screen video, but I'd prefer no to share it here in the community as it has personal info attached.