Repeat Actions not working (SunCalc)

I'm trying to set up the SunCalc driver ([RELEASE] SunCalc Driver) to help control my blinds and cannot work out getting things to update. Initially, "The Sun" device would not auto-update, but toggling Auto-Update off and back on fixed that.

Now I cannot get the Suntracker app to repeat and run the included actions. This is my first attempt with repeating actions. If I Run Actions in the app, it updates the hub variables Altitude and Azimuth, but does not run again even though the app says "Repeating". The app has also stopped displaying the "Repeating" identifier without being stopped. The Suntracker app is being run by another app at 30 mins before sunrise. See images below.

Structurally, I don't see anything wrong there (though the repeat is marked as "stoppable" but not actually stopped anywhere--but that won't cause this problem). However, I also don't see evidence of failure in the logs; your repeat interval is 10 seconds, but there were only about 6 seconds between the time it started waiting and the time you must have hit "Done" or "Update Rule," either of which writes that "Initialized" line you see in Logs and erases this repeat schedule. Could that be your only problem?

(Also, if this rule "runs" pretty much all the time, 10 seconds is a pretty frequent interval and I'm not sure I'd do that, but that's also not the problem here.)

Isn't that 10 minutes, not 10 seconds?

Sorry, yes, read that wrong. :slight_smile:

But that makes the question I asked even more of a concern.

Good question. The only ongoing issue I have is with iBlinds not always responding, but that is not new and I don't think it's related. The logs only show recurrent warnings from an empty string from the Battery Monitor app.
Screenshot 2023-09-08 133334

...and an error from the Ambient Weather Station reporting a missing particulate monitor (I never had one). I'm not sure how to tell the device that monitor does not exist.

I see nothing else in the logs. I suppose I could restart the hub.

What I meant is that I don't see a time in the logs while the repeat was in progress where you waited 10 minutes (to give it a chance to repeat) and didn't hit Done or Update Rule (which will reinitalize things, including canceking the repeat).

Rebooted hub and still can't get the actions to repeat. Any other suggestions?


Can you confirm that you have waited long enough without re-initializing the rule, and what do the logs say in that case?

Also, there is a known issue in 2.3.5 with "repeat n times," which you don't have, but I suppose it's possible there's something with unspecified numbers, too...that will be fixed in 2.3.6.

I definitely waited long enough (over an hour). I made another repeat test app which also isn't working. Is there any other way to make a repeatable action pending release of 2.3.6?

Not without writing or modifying a custom app or driver (or doing what you need without the rule?), but you could also join the beta program and try 2.3.6 if you want. :slight_smile:

I didn't know there was a beta program. Request submitted!

I'm on and still having repeating problems. I made a test repeating app to update a hub variable by adding 1 every 10 seconds for 10 reps and it only adds once. Am I doing something wrong? I'm triggering manually by running the actions in the rule. It does say the rule is repeating.

Screenshot 2023-09-29 104448

I don't see anywhere where you waited at least 10 seconds for your repeat to complete before hitting Done (or Update Rule), which is where those "Initialized" log entries come from. This is important because either will un-schedule any repeats. This is the same problem I asked about above and I'm not sure was ever answered (though the log entries you provided only show evidence that the answer is "no"):

I'm not sure how to show the absence of something in the logs. I'm refreshing the hub variables to watch for the counter to increase and it does not - even after 10, 20, 30...seconds.

I just tried triggering the app with a virtual button, not via the run actions and it does work that way. So it appears its doesn't repeat when triggered from within the app.

What I was (and still am) wondering is simply: have you waited longer than 10 seconds without hitting Done or Update Rule? You did this multiple times within 10 seconds according to the logs you do have, which again is important to note because that would cancel a repeat. (If you are just trying to "close" the rule and let it continue, just close the page -- or navigate somewhere else -- without hitting Done.)

I am not able to replicate your problems. With a new rule, here is the first few repetitions I got after hitting Run Actions, which I did right between "Initialized" and my first action:

The rule is:

I again strongly suspect you are doing something like hitting Done to close out of the rule before your repeat finishes -- i.e., this old issue again. :smiley:

I was hitting done. I didn't understand that it would stop the repeating actions. Interestingly (and added to my misunderstanding), the rule does continue to say it's repeating even after I hit done leading me to believe it was still active.

Screenshot 2023-09-29 114227

The Done (or Update Rule) issue is so important that I asked it in my very first response and, without a direct answer, continued to bring it up in several posts thereafter. :slight_smile:

Not sure what is going on with that "indicator," however. They're normally accurate, but there have been a few bugs in the past where they get stuck in the wrong state for one reason or another. Logs are really key to know what is actually happening (or not). Glad you got it figured out!

Thanks for being persistent. I clearly read right over that!