Repair unresponsive Z-Wave device?

Due to a very worn out and loose electrical outlet in the bedroom (which I have addressed with my landlord and is not the point here), the plug for my nightstand lamp will fall out if you breath on it. Sometimes the lamp flickers several times within a few seconds due to the loose connection. When this happens, the bulb in the lamp (LinearLinc LB60Z-1) becomes totally unresponsive. I've had to exclude the device and re-add it. This, of course, means I then have to fix all of my rules and such, and I really don't want to have to do that every time. I've tried power cycling the bulb and the hub, and run a Z-Wave repair, and nothing seems to get Hubbitat to reestablish communication with the bulb except for exclude and include. Is there anything else I can try?

Try making a group, put this bulb as the only member of the group, use the group in your rules and automations. That way, when you exclude/include the bulb, the Automations and rules are untouched.


I suspect that this flickering is triggering the bulb’s factory reset command, which is typically to quickly turn it off and on for X number of times.

Using a group in this case is probably the best approach.

That said, an other option would be to:

  1. Pair the bulb again
  2. Copy the Device Network ID (DNI) of the newly paired instance of the bulb and click on “edit” (It will complain, that’s okay) to add an “A” at the beginning, then save it
  3. Paste the DNI that you copied from the new device to the DNI of the original device
  4. Delete the new device from the “device” section. (It will say that it has activated the Z-Wave exclusion mode, just wait until that expires and confirm deletion.)
  5. Go to the “Z-Wave Details” screen and delete the original device (keep the new one as it is the one with a valid paring now)
  6. Enjoy the fact that the bulb works again and it didn’t require you to change all your rules again...

I have done that on several occasions for various reasons and it is a definite time saver!


Thanks, guys. You know, what? I have two night stand lamps and I already have a group called Bedroom. There is no reason I couldn't use the group in my automations, since I almost always want to set both lamps to the same level simultaneously. (Bedroom lights on, lights off, lights at 50%, etc.) Good trick.

As I was reading this, I thought you were going to tell me to copy the ID of the old device before deleting it and manually changing the ID of the new device to match. Would that also work? Either way, are you saying that you don't have to delete the old device before adding the new?

No need to device the old device at all (under devices). The ID of the new device is how the device is linked to it’s Z-Wave address. (The ID is the Z-Wave address.)

That said, I realize that I missed a step. You need to go to the “Z-Wave Details” screen and delete the old pairing. Otherwise, you create ghost nodes and will possibly have issues later on. I will fix it in the steps above...

To help with the looseness, take a littlebit of solder and apply it to each prong on both sides to thicken it up. Spread the prongs themselves slightly. This should help you achieve a better outlet connection.


@rlithgow1 Thanks for the suggestion. Hopefully this is very temporary and I'll have new outlets soon.

1 Like

I haven't done this yet, but thinking this through, I'm a bit confused. Steps 4 and 5 seem to conflict. Could you please elaborate? Also, if I am keeping the new one because it is the one with the valid pairing (makes sense), why am I modifying its DNI?

I don't see any option on the Z-Wave Details screen to delete anything. Do I need to click on the device name to go to its page and scroll down and click Remove Device? If so, why navigate there from the Z-Wave page and not the Devices page that I was already on? I feel like I'm missing something.

If it were me I would just replace the 68 cent outlet and not be dealing with the hassle. But I'm old fashioned.


Again, that is being dealt with. And that doesn't solve my immediate problem of re-adding the device now.

Duct Tape or epoxy.

Let me give it a try... :blush:

When a device is paired, two things happen.

  1. The physical device (the bulb) asks for new connection information on the Z-Wave channel. When Hubitat is in pairing mode, it listens for this and recognizes that a device wants to connect. It sends it the information it needs to connect to the Z-Wave mesh. The physical devices then replaces the Z-Wave information it had in its memory with this new information. This includes a Z-Wave ID. This is the ID that appears under “Z-Wave details” (In both hex and decimal formats). When the physical devices communicates with Hubitat afterwards, it provides this Z-Wave ID.
  2. Once Hubitat confirms this device has joined the Z-Wave mesh, it creates a logical device within Hubitat. It gives it the same ID (in Hex format) as it gave the physical device. When Hubitat or the physical device sends and receives commands to each other, they uses this same ID.

In Step 2 and 3, you take this Z-Wave ID and give it to your original (old) logical device. This means that when Hubitat receives commands, it knows that they belong to the logical device with the same Z-Wave ID.

In step 4, you then delete the new logical device that will do nothing from that point on since it no longer has the correct Z-Wave ID (because you added an “A” to it). It will no longer be in use as it has been orphaned.

All this time, Hubitat’s Z-Wave chip thinks that the (old) device ID that it gave the device the first time is still valid and may try to talk to it, or route other devices through it. It doesn’t know that it is the same device as the new one it just paired.

In step 5, you are telling Hubitat that the device with the original Z-Wave ID no longer needs to be registered on its network. This ensures it won’t try to route other devices through it.

To do this on a C7 hub, you click on the “Refresh” button under the status row. On a C5 hub, you need to wait until Hubitat eventually realizes that the device is no longer on its mesh and offers you the option to remove it.

Does that help?

(note: Z-wave experts might recognize that the order of some of the steps are not exact...)


Kind of. Still not sure I full understand what is happening, especially in step 5, but I followed the steps and everything is working. Very nice to know that my dashboard button for this device still works, which I was worried about and forgot to specifically mention in my original post. Thanks for the help!


I just had to do this again due to a power flicker that reset the device. The outlet has been replaced. See? There are other valid reasons to do it. Anyway, following the steps is simple enough and works like a charm. But I'm still confused on the how and why! I understand that what we are doing is assigning the newly-created device ID that was created when the device was paired this most recent time to the old device on the hub. I'm not sure I understand why this is done and not the other way around. I would think we would need to tell the hub, "See that new device we just added? That's really the same as this other device that was already there, so use the same ID as that old device." Seems backwards to me, so I know I must not be thinking about it quite correctly.

I think that might be possible in some instance on the C7 using the “discover” button on the Z-Wave details screen if it comes up.

What I understand is that when you pair a new device, the Z-Wave part of the hub, which is as I understand it its own independent “device”, doesn’t have any way to know that the item you are trying to pair should take the place of the old one.

I certainly agree with you that it would be nice if there was an easy way to replace one Z-Wave device with another. There must be a reason it is not currently a possibility… @bcopeland would know. (And he might also correct my assumption…)

Zigbee does work the way you describe as long as it is the same device, it will use the same “slot”. You cannot pair a new/different device however and have it take the “slot” of the old device.

Are we talking about replacing a failed z-wave device? If so:

This is the only way to keep the same node id.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.