Removing Ghost Devices


I've googled this like crazy and sifted through dozens of different posts, but some are outdated. I have an Aeotec sensor that seemed to fail to include and I have TWO ghost devices of this. I can't add any other Zwave devices right now - I am wondering if there's something weird going on.

I saw this can be done using PC Controller - is this still a thing? The posts were outdated.

I do see the "remove" option in my Zwave details page for the device ID (25,26).

Any ideas?

Always a best practice to remove any ghost devices before trying to add more. Try the remove option if presented on the Zwave details first, but the PC Controller with a Zstick is still an option if that doesnโ€™t work.


@danabw put together this awesome guide on how to use PC Controller:

PC Controller and an external stick is worth the investment. But will admit it can be frustrating to use too. I had several switches fail earlier this week after a storm knocked out our power and had to use it to remove the failed switches. Took many tries on a few of the switches.

1 Like

Hey - Thanks. I have a Aeotec ZStick - brand new. Can I use this?

I couldn't get the software I needed from that guide! It seemed awesome until I couldn't seem to find the PC Controller in the listed directory. I have both v4 and v5 installed on my PC right now, and the ZStick is recognized by Windows.

I tried to remove them in the devices page :frowning:

It just refreshes after a few seconds and it is still there. Also, the device is POWERED OFF. Lol, made sure of that one.

It may take multiple tries, I've had them persist through five or six tries, then get removed on a few cases.

If that doesn't work, here an updated thread I created:

The stick you have will work.

Post a screen shot of what's happening to you getting the software to work.


A note about removing ghost nodes from the zwave details page. Even though the page may refresh, the operation still may be active.

I recommend having both the zwave log and the log open in other windows at the same time to see background activity.

I recently had an S2 inclusion issue and overall I have found removing ghosts via the zwave details page more reliable. Hitting the Refresh for some reason sometimes helps. Still not 100% and I did have to use the zwave stick a couple of times.

1 Like

OK - I managed to get this working - looks like I totally spaced reading the documentation properly. It is under the 'Tools' menu. :rofl:

Aeotec ZStack works like a charm. I included it following the guide and used the 'removed failed'. It immediately went away.

I then tried adding the Aeotec Trisensor again, and I got the same result. I tried this multiple times. So after removing it via PC Controller a few times, I guess I've determined this device is bugged. I'll be getting a refund. After the ghost devices were removed, I was able to add my Innovelli dual plug instantly. Previously with the hung up and bugged ZWave network, it wouldn't even show up to add.

Thanks all! This community is awesome, responsive, and very helpful.


You could try adding it via Zstick and PC Controller with no security. Then once added you can remove the Zstick and it will remain working with your hub. Iโ€™ve had to do that with devices that refuse to pair with no security.