Remove z-wave device that is not in device list

I tried to add an ULTRALOQ Smart Lock U-Bolt Pro z-wave device to my hub. It seemed to try but failed. It doesn't show up in my device list, but I see it under Z-Wave Details:

I tried "Repair" to no avail. I tried "Z-Wave Repair". I've tried a hub reboot.

How can I get this entry above out of my db?


My Hub is a C-7 at firmware

Use PC Controller from SiLabs.

If you know which device it is you can try Devices: Add Device: ZWave: Exclude, then dance the dance on the device to start Exclude. It's the generic Exclude but since the hub does know about the device, it will detect that and remove it.

I see you identified it as a Lock and if it didn't include using Security (S0 or S2) then, yea it won't work well.


Try a "Refresh," then waiting a minute or so. You may see "Remove" then. If not, try another "Refresh," wait a bit again, then see if anything changes. (Sometimes these devices are stubborn, and coming back a day or two later might even help.)

A "Repair" isn't the operation you want to perform here, in any case.


See this guide: How To: Remove Ghosts using hub tools or a UZB Stick

When you tried to include it did you by chance select no security? If so, that is why it failed. Locks will only pair with security by design, if you pick no security the lock will refuse to pair.


Thanks csteele, this worked. I also had to do the "Refresh" that bertabcd1234 suggested - it made the "Remove" popup. Also, thanks to jtp10181 for the tip on security - that was where I went off the rails.