Remote admin don't work

Hi: my REMOTE ADMIN subscription is current until July 21, 2024. I cannot access it. What should I do?

What does Registered Hubs show as your subscription status?

1 Like


White page when go to remote button...

Tagging @support_team

@userLP24 - can you confirm your hub is connected to Hubitat’s cloud?

1 Like

Excuse my ignorance, how can I make sure? I have used the REMOTE function in the past and it worked. Could this be the problem?

Yes. Remote Access requires your Hubitat hub to be connected to Hubitat's cloud.

Are you close to your hub right now?

1 Like

No, I'm at work...tell me what to do and I'll do it when I get home. Thank's

Well, the fact that the “Connect to Hub” button is greyed out seems to indicate that the hub is offline (no power or red or blue light, rather than a green light). So, while there could be a firewall issue preventing the hub from accessing the Hubitat cloud, it’s likely that the hub has lost power (no light) or that it has crashed/stopped (red light) or that it hasn’t booted to the hub platform (blue light rather than green light).

Those are he things to check when you get home. Let us know.

Your screenshot indicates that the Remote Admin subscription is active.

1 Like

No, it would be greyed out if your mobile device isn't connected to the same network as the hub.

@userLP24 on the same page that you've shared earlier, select "Hub Details" if the last check in is not today, or Active? field shows "No", then your hub is no longer connected. These are the fields you are looking for on the right hand side:



Here is the page:

Well, it seems like you are in the middle of an internet outage and my.hubitat didn't catch up with it, yet. I checked your hub and is not connected to the cloud. By the way, let me know if you'd like me to update your community user name to be less revealing of your email address.

1 Like

Hello: thank you @bobbyD for the possible solutions. I solved the problem with this help. I use a DNS server with a Pi-Hole (my son set it up for me). I realized that when I deactivate it for certain online shopping sites for example, I am able to use REMOTE ADMIN! So, I used the Hubitat hub function to go over the DNS of my wi-fi and wired network (I inserted Hubitat's suggestions for the NETWORK SETUP function (DNS servers run by well known providers, for example,,,, I just tested it again, it works fine, I am now able to use Remote admin. Hope this can help another user. Bye!