[RELEASE] Z-Wave Firmware Updater

Oh I actually got past this on a different switch:

dev:662020-05-04 12:26:18.512 pm debuglocked by:

dev:662020-05-04 12:26:18.453 pm warnUpdate failed to find a valid target

dev:662020-05-04 12:26:18.177 pm infocalculating crc...

dev:662020-05-04 12:26:17.886 pm infofirmware total bytes: 65536

dev:662020-05-04 12:26:17.882 pm infoSorted all the bytes. cleaning up some memory...

dev:662020-05-04 12:26:00.242 pm infoVersionReport- applicationVersion:1.17

dev:662020-05-04 12:26:00.226 pm infoVersionReport- zWaveProtocolVersion:4.33

dev:662020-05-04 12:26:00.011 pm infoFirmwareUpdateMd version:4

Current States

  • manufacturerId : 2F00
  • firmwareUpdateProgress : Failed to find matching firmware
  • firmwareTarget : null
  • firmwareUploadPercent : null
  • currentFirmwareVersion : 1.17
  • firmwareFragmentSize : 40
  • firmwareId : FB3D
  • lockedBy : None

I'm using this firmware: https://raw.githubusercontent.com/djdizzyd/hubitat/master/Drivers/Z-Wave-Firmware-Updater/Leviton-DZ6HD_01_20.hex

1 Like

This is saying the firmware ID in the hex file didn’t match what is on the device

This is also suspect.. Total bytes should be larger

Give me a minute to look this over

Awesome thanks.

I realized that I didn't have the debug logs on for this switch. Adding it below in case it gives any mroe information;

dev:662020-05-04 12:39:36.594 pm warnUpdate failed to find a valid target

dev:662020-05-04 12:39:36.580 pm debugFirmware Descriptor: [wFirmWareCommonSize:42683, wFirmWareBank1Size:40950, wFirmWareBank2Size:30263, wFirmWareBank3Size:8744, manufacturerId:12032, firmwareId:64317, checksum:27506]

dev:662020-05-04 12:39:36.352 pm infocalculating crc...

dev:662020-05-04 12:39:36.317 pm infofirmware total bytes: 65536

dev:662020-05-04 12:39:36.314 pm infoSorted all the bytes. cleaning up some memory...

dev:662020-05-04 12:39:36.311 pm debugParser: EOF

dev:662020-05-04 12:39:24.880 pm debugParser: 16 bit shift: 0x0

dev:662020-05-04 12:39:24.840 pm debugpacking all the bytes...

dev:662020-05-04 12:39:23.236 pm debugfirmwareMdReport: checksum 15691 firmwareId: 257 manufacturerId: 29 maxFragmentSize: null firmwareTargets: 0

dev:662020-05-04 12:39:23.224 pm debugFirmwareMDReport: FirmwareMdReport(manufacturerId:29, firmwareId:257, checksum:15691, firmwareUpgradable:false, numberOfTargets:0, maxFragmentSize:null, firmwareIds:[])

dev:662020-05-04 12:39:22.891 pm infoVersionReport- applicationVersion:1.17

dev:662020-05-04 12:39:22.887 pm infoVersionReport- zWaveProtocolVersion:4.33

dev:662020-05-04 12:39:22.662 pm infoFirmwareUpdateMd version:4

1 Like

weird.. That should have matched... Give me a bit

Following back over here from:

Of which the latest firmware can be found here:

Then to my dismay and reading in other forums that there is no OTZ or HEX for Aeon devices but apparently some have extracted them from the .exe that is provided for their automatic updater that apparently others have been able to extract the HEX file from the binary.

I tried the 1st of my LZW30-SN On/Off switches and had to follow the above steps and be ready to push that air gap switch in quickly but it updated fine after that. Before it just kept nagging to wake up the sleepy device. Now just a dozen more or so to do. Thanks to @bcopeland for the excellent tool and thanks to @gavincampbell for figuring out the sequence to wake up those LZW30-SNs!


So I just saw that Inovelli released 1.17 this weekend for the LZW30-SN but I'm not sure how to get the URL, I may download it and put it on an internal web server unless someone knows how to get the URL? Thanks.

Unfortunately 1.16 didn't correct the sleepy device issue, going to 1.17 I still had to follow the above steps. I downloaded the firmware to my internal web server temporarily and created the mime type so it could be downloaded then used that URL. I plan to just run that update on one switch for a few days since I haven't seen anyone else update to it yet to make sure it doesn't introduce a new issue.

1 Like

Wish there was a "legal" way to share all of the updates in a repository verses each person having to make multiple requests. :slight_smile:

1 Like



Right.. I would love to have a massive repository of firmware files.. The aeotec and leviton are what I would consider "grey areas" because they are on their website, just not in the correct form (exe extraction). But others that verify purchase prior like zooz, I wouldn't put that up as this would not be a grey area..

1 Like

Thanks, Erik replied with this address too...

1 Like

I'm curious... How are you able to get the Inovelli firmware link? I have tried a few times to get the link to their latest firmware (1.17 for the Red series switch) but all I seem to be able to do is to download it... :frowning:

That said, I see you added the link, so will use it! :slight_smile:

1 Like

In your browser on the downloaded file, right click and select copy download link

1 Like

For whatever reason, that isn't working for me on the Inovelli firmware files... I've never seen that before, very odd...

Your link worked great though! Firmware uploaded, device is flashing...

1 Like

I saw this app for Windows 10 from Windows store, Simple http server. Pretty straight forward for setting up. The otz and hex file can be save locally then just paste the generated address into the firmware updater app.


Any ideas on what's mismatched? Am I using the right FW? I'm not sure what the difference is between the HEX (on the github) and the HEC (I found in Z-FLash), though I'll assume the 'c' stands for compressed or something?

1 Like

HEC is an encrypted format and will not work..

HEC files will only work in HomeSeer's Z-Flash software

Thanks for this, I'll have to keep it handy as I think it can work for other Inovelli files if you know the version number of the firmware you need.

1 Like

Thanks, good to know. I guess that leaves the mystery of why it's failing to find the FW/mismatching

1 Like

I've now updated all of my LZW30-SN on/off switches to 1.17.

1 Like