[RELEASE] Z-Wave Firmware Updater

Yeah, I would do that also, except I had an issue with power reporting and also an issue with it hard freezing. The original firmware might have been an issue. Given how many times I tried to fix it and now how many times it took to do the update, Fingers crossed this will solve the issues.
So far so good.

1 Like

This is not currently a possibility .. There are provisions in command class versions that I haven’t seen on devices yet, and there is no guarantee that the manufacturer will support then


Got it. Thank you. :slight_smile:

1 Like

I have a ton of Zooz Zen22 dimmers that i need to update. By chance was that one of the Zooz products that has problems with this updater? I REALLY don't want to have to exclude and repair, and have to redo all my automations.

1 Like

Not sure

1 Like

I did one of these and several Zen21 switches. The firmware updated fine, but also reset the switches. If I were doing it again, here's what I would do:

  1. Replace the first switch in rules/apps with a placeholder virtual switch
  2. Update the firmware on the first switch
  3. When the update is complete, check if the switch is still paired to HE. If it is, all you need to do is replace the placeholder switch with the real switch. If it isn't, then:
  4. Exclude the switch
  5. Include the switch
  6. Replace the placeholder switch in rules with the newly included switch
  7. Proceed to the next switch

Edit: I didn't do step 4 and it messed up my z-wave network within a day. But when all is said and done, the firmware update was totally worth it. Thanks @bcopeland for providing this tool, and @agnes.zooz for the firmware files. Also thanks @bobbyD for helping me identify what I had done to mess up my z-wave network!


What do you mean by this? Change the driver from Zooz to a virtual switch? Or go into each rule that the Zooz switch is used in, and replace the Zooz switch in the rule with a virtual switch? If it’s the latter, that’s going to take a lot of work if there’s a lot of rules isn’t it? If it’s the former, how do I check if the switch is still paired in step 3?

1 Like

I would like to give a shout out to my amazing beta testers @aaiyar @erktrek and @BorrisTheCat.. These guys gave amazing feedback which helped a lot!


This. Yup. It takes time. But if you don't do it, you'll end up with corrupted rules.


Same for groups, scenes, and dashboards?


Yup - all apps.


Wow upgraded my on/off switch today and worked great! Thanks for all your hard work!


Has anyone successfully updated their Inovelli Red Dimmer with the light bar firmware? I know the file is in .bin format and needs to be .hex. I used the Silicon Labs .bin to .hex tool and when I tried to load it onto the switch, I got the error firmwareUpdateProgress : Failed to find matching firmware.

Looking at the logs, it seems the .hex file maybe isn't in the expected format.

firmwareUpdateProgress Failed to find matching firmware DEVICE 2020-04-19 07:36:15.389 AM EDT
firmwareId FFFF DEVICE 2020-04-19 07:36:15.363 AM EDT
manufacturerId FFFF DEVICE 2020-04-19 07:36:15.360 AM EDT
firmwareUpdateProgress Calculating CRC... DEVICE 2020-04-19 07:36:15.213 AM EDT
firmwareUpdateProgress Padding hex bytes... DEVICE 2020-04-19 07:36:14.973 AM EDT
firmwareUpdateProgress Parsing firmware... DEVICE 2020-04-19 07:36:07.499 AM EDT
firmwareUpdateProgress Downloading firmware... DEVICE 2020-04-19 07:36:06.457 AM EDT
firmwareUpdateProgress got device current metadata DEVICE 2020-04-19 07:36:05.325 AM EDT
firmwareUpdateProgress Getting firmware meta data... DEVICE 2020-04-19 07:36:04.833 AM EDT
firmwareUpdateProgress Starting.. Getting current version DEVICE 2020-04-19 07:36:03.881 AM EDT
1 Like

I still have no luck with my LZW30's. This morning i did a factory reset on one of them and still no luck.

I did find that after the first time you attempt this and get a "sleepy device" message, the switch is actually is a bad state. PRessing the config button 3 times does not initiate pairing mode. Once you air-gap it, pairing mode will work again.

Don't know if that's helpful.

1 Like

Yep.. I ran into the same thing.. It’s not finding the firmware descriptor in the image

1 Like

I think I got past the Inovelli LZW30 issue! I noticed some LED activity during the update process and noticed the switch seems to not ever reply to two commands from this driver in a row without air gapping.

For anyone having trouble, try this:

  1. Abort and release lock of any prior attempts
  2. Air Gap your switch and plug it back in
  3. Start Firmware upgrade
  4. Watch the process, and watch for "Current Firmware version obtained" (or something similar to that)
  5. Immediately air-gap your switch and plug it back in (it has to be fully "re-booted" while the updater is downloading/parsing the firmware)
  6. For me the "Request to apply firmware", was then immediately successful

Unfortunately I cannot replicate again to see if it works since I dont have another LZW30 to try on.


That Worked!! I didnt even have to do step 4 & 5. i just air gaped the switch and then immediately hit the update firmware button. I missed the "Current Firmware version obtained" but the upload still went through. Thanks!


That worked for me also. I also like @EAN didn't have to do the last two step. Does it tell you that the update is done? etc.

1 Like

It sends the last message (as long as the device sends it) stating that it is complete and flashing and that it will restart when done..

But there is no standard for when the device boots back up so I have no way of representing that