[RELEASE - UPGRADE] Netatmo (Connect) - Simple netatmo interface

Thank You! I'm a beginner. It's working. I couldn't set the temperature to Celsius. Could you help me with that?

I think it uses whatever you have set in the actual Netatmo mobile app (not hubitat app).
Take a look at "Settings - My Account - Personal Data - Units". In the Android Netamo app settings is the three horizontal white bars in the top left corner.
Hope that helps.

Unfortunately, the mobile has metric data. The other problem is that the data from the two netatmo bases does not appear between the devices. I may need to reinstall the base driver.

Hey got everything connected but seem to not be able to get all the modules created, They are all there only the outdoor device shows up as a device the base unint and extra room monitor don't show up

Can you tell me if this software supports multiple stations? I have two weather stations, but only one of them is loaded. Can you suggest a solution?

New here too. Installed the app driver but when I want to add the new user-app i always get an error that 0auth is not working. I see others have got this code working. Is it still working in C7 and under the latest updates ?

I can't speak to the C7 as I have a C5, but I'm on the latest HE firmware (2.2.6.140 at the time of this posting) and it's working for me with 1 main indoor module, 2 indoor air modules, 1 outdoor temp module, and 1 outdoor rain gauge.

It's been a few months since I set it up and now can't remember the exact steps I had to go through but I do recall some trial and error, and that I had to create an account here: https://dev.netatmo.com/apidocumentation/ to get my API credentials as my normal username/password for my Netatmo account didn't work for authentication via Hubitat. Once I had the new API credentials I was able to get everything working using those.

I know this is an older post, but I didn't see an answer.
Yes it does. I have 2 stations and just moved off of a the HubConnect Netatmo Client to this client. I had disconnect issues with the other app and could not get it to see my other station. This app connected up just fine. The OAuth page opened in the same tab instead of a different window, but once connected, and I used my back button instead of actually closing the tab, I was able to connect the app to my Netatmo and see the modules from both stations.

@cybrmage - Are you aware of any recent changes? Either on the Netatmo side or within the code? I have two Netatmo units and they both were appearing when I connected my Hubitat to Netatmo using your updated drivers/app. However 2 days ago my second unit stopped updating and now those devices do not appear in my list of units. They are still online and reporting to Netatmo just fine. In fact, in my primary HE hub, they have do not appear in that drop down list either. I can see the Station name and modules in the response field within the app though.


Any ideas?

EDIT: I don't know when, but both stations began appearing again. Must have been an issue with Netatmo.

Hi all, my devices appear to be working fine and reporting data fine but in the logs, I can see these cyclical app errors:

app:1942021-12-21 22:43:40.859 debugrefreshToken: completed
app:1942021-12-21 22:43:40.858 errorrefreshToken: Error: groovyx.net.http.HttpResponseException: status code: 400
app:1942021-12-21 22:43:40.613 debugIn refreshToken
app:1942021-12-21 22:43:40.612 errorNetatmo::apiGet: Call failed groovyx.net.http.HttpResponseException: status code: 403, reason phrase: Forbidden
app:1942021-12-21 22:43:40.343 debugrefreshToken: completed
app:1942021-12-21 22:43:40.342 errorrefreshToken: Error: groovyx.net.http.HttpResponseException: status code: 400
app:1942021-12-21 22:43:40.027 debugIn refreshToken

Any idea what might be causing this?

Hi, all my devices work fine as well, but I keep seeing this error in the logfile:
errororg.codehaus.groovy.runtime.metaclass.MissingMethodExceptionNoStack: No signature of method: user_app_fuzzysb_Netatmo__Connect__64.refreshDevices() is applicable for argument types: () values: [] (refreshDevices)
Any idea?

Hi All,
thank you for this work. I am trying to get my Netatmo weather station working.
I tried different apps and drivers, but none worked.
I installed first the app, created an app in the Netatmo page and got user Id and pass from there, imported into this app. After setting the variables settings, it seems to work. If I check the app state, I see all the info, including the mac address of the 3 devices (base, outdoor and additional module), and all the supposed info pooled from the devices. I then install the devices, installing the drivers and choosing the driver from the virtual devices. At this point I do not see any data from the single devices. That said I assume that the problem is in installing the devices. Anyhow, I do not see any data anywhere else than in the app state. I do not understand what am I doing wrong.

I figured out myself that there are devices created automatically by the app (I guess) and I do not need to install manually the drivers and create new devices.

1 Like

When trying to set this up, I got it to connect, however in the devices drop down, nothing shows up. Any ideas?

I think I had something similar. What I did to resolve it was after the window changed and authorized Netatmo, I used the back button in my browser to return to the previous screen. Then I saw the items in the drop down.

That did it. Thanks!

1 Like

G'day All, seeing as cybrmage hasn't been around since 2020, I've taken the liberty to clone this app to my GitHub, make some minor tweaks and publish it via HPM:

Be warned, I'm not a real Dev, just a tinkerer so please don't expect huge changes - I'm able to implement tweaks and bug fixes.

@bobbyD could I please be given ownership of this forum topic?

I've also written an RM 5.1 Rule (available from my GitHub below) that uses a Smart Switch to detect when your Netatmo Basestation stops communicating back to the clouds servers and will power cycle it.

Netatmo Weather Station - Offline Recovery.json

2 Likes

Why not start a new thread under the new management and leave a link here for others to follow?

2 Likes

Good idea.

EDIT: New Topic is here:

1 Like

Download the Hubitat app