[RELEASE] Tuya Zigbee Smoke Detector

Hi @user3186 ,
_TZ3000_r6buo8ba should be a power reporting smart plug, it is supported in this driver.

1 Like

does anyone know if there is a way I can test the alarm for Ts0601 please? it looks like this can be done if the alarm is connected through their own gateway?
there is no button on the body of the device to test either

If you have any details on how this is done using the Tuya gateway, please let me know. Do you have any PDFs or YouTube videos showing some details?
Have in mind, that there are at least 5-6 different 'TS0601' smoke alarms, so your device may be different.

I don't have a Tuya gateway. But in the instruction manual that was it says it can do through the app
my is

  • endpointId: 01
  • application: 48
  • inClusters: 0004,0005,EF00,0000
  • manufacturer: _TZE200_ntcy3xu1
  • model: TS0601
  • outClusters: 0019,000A
  • softwareBuild:

What Tuya app ( SmartLife ) does is to simply show on the mobile phone screen 'Smoke Detected' when the button is pressed.

This is a real alarm test and will activate all of the notifications, sirens, alarms, etc.. that you may have configured in Hubitat.

What we need is probably a combination of an Hubitat app (or simply set of HE dashboard tiles?) that will put all the smoke detectors in a virtual testing mode for a time limited period. During this testing period, the driver will generate not a real 'smoke detected' event, but 'smoke tested' when the test button is activated or even better, when a real smoke test is performed. The testing mode should be terminated either from a button on the app or by timeout (10 minutes maximum time for testing, then the smoke detectors will be armed again).

Does anything like this exist already for other (non-Tuya) smoke/gas alarm sensors?

"Tuya Zigbee Smoke Detector" driver was updated to ver. 1.1.0 via HPM :

  • extended tuyaMagic (hopefully activates check-in every 4 hours);
  • added capability 'Health Check';
  • added ping() command and rtt measurement;

The previously misused Presence capability is now removed and replaced with the healthStatus (online/offline) attribute.

1 Like

I would like to thank you for the tuya zigbee driver, the Tuya zigbee smoke detector works really well, only thing I had to do is when I paired the smoke detector, I had to put the smoke detector on top of the hubitat hub whiles it was pairing so it would pair properly, I had to do that with the Tuya zigbbe motion sensor as well, I have wrote a rule so when the smoke detector detects smoke my Danalock will unlock automatically if I'm home,

1 Like

The First Alert Smoke/CO detectors send a “test” message when pushing the test button.


Hi please can you help I have 2 AwoX bulbs and they have worked fine for 2 years on my Hubitat 5 hub, I have upgraded to Hubitat 8 2 days ago and worked fine but today both bulbs have stopped working, I've tried to repair them and they show up but they won't turn off or on. Thanks Tim

Hi Tim,

AwoX bulbs use Bluetooth communication... How were yours integrated to Hubitat?

As this thread is dedicated to Tuya Zigbee smoke detectors, it may be a good idea if you create a new thread for these bulbs, so there will be a better chance for more people to see it and respond.

Hi ,Thank you for you reply, the bulbs definitely are zigbee, they been working on the c5 hub, its only since I've upgraded to c8, I've just removed the bulbs from the hub and added them again but the bulbs will not come out of pairing mode.

There are still hiccups with some Zigbee devices pairing as a side effect of the new Zigbee 3.0 chip support in C-8 …

Hopefully these will be fixed in future HE platform updates.

1 Like

Yes hopefully, thank you again for your help, it is greatly appreciated.

1 Like

Hi @kkossev ,
Using your driver latest version 1.1.0 dated 7/4/23.
I am getting these error messages:

I am on the latest hub version
And the device details are:


I can not say the error message was not there before but I did not remember seeing them

1 Like

Thank you for the report, @amithalp !

You can try the fix in the version 1.1.1 and let me know if the error is gone.

Also, please check the Events history - is your Smoke Detector reported as offline periodically or not?

Manually installed version 1.1.1 nas it did not show up in HPM.
For a reason I do not understand the device page keep the presious version data:


When I click the ping botton with the debug option activated I get this log:


My device event log is not showing Offline but is short.


Update - I went up this post and got reminded that (at least when manually updating the driver) a new repairing process had to be done.
Took the device close to the hub and did a repair process.
The driver details are now showing correctly.
I will keep updating with regards to previous erorr messages.

Yesterday I experimented adding the Beta version of another driver to be available for updates from HPM, but without much success.. :frowning: A missing comma in the manifest JSON file and misleading error messages from the HPM (because of try-catch sections that include at least 3 different reasons for that exception) took me several hours to troubleshoot, so today after finding the typo and restoring the HPM updates, I give up for now.... In HPM, currently there is one global setting enabling the Beta versions update for all drivers, not just for the one that you are interested in.

The easiest way to install a beta version (from the developments branch) is manually, by clicking on the Import button :

Import Button

The above is true for my drivers, which importURL always points to the latest development branch version, but may not work for other drivers. There is no standard here...

No, usually you don't need to pair the device again to HE when updating the driver. Re-pairing is needed only once if the driver was not selected automatically the first time when you added the device to HE.

Let me know if the Ping button works for you with the latest version. Also, please post the device/manufacturer of your smoke detector, I can't find it in your previous posts. There are at least 3-4 different Tuya smoke detector models and seems like they are behaving differently in regards to whether these can be pinged or not.

Yes it does:

Log for ping with debug ON

Manufacturer is - _TZE200_ntcy3xu1

1 Like

can't get mine TS0601 to work. I can see the battery level and the health. But no smoke or clear report when I test it.

  • packetID : 0
  • rxCounter : 39
  • isDigital : true
  • driverVersion : 1.1.1 2022/04/29 10:56 PM
  • pingTime : 1690846341087
  • txCounter : 5
  • notPresentCounter : 0
  • model : TS0601

[dev:121]logs?tab=past&deviceId=121#)2023-07-31 04:38:25.310 PM[warn]/logs?tab=past&deviceId=121#)map= [raw:catchall: 0104 EF00 01 01 0040 00 4A25 01 00 0000 02 01 00D46501000100, profileId:0104, clusterId:EF00, clusterInt:61184, sourceEndpoint:01, destinationEndpoint:01, options:0040, messageType:00, dni:4A25, isClusterSpecific:true, isManufacturerSpecific:false, manufacturerId:0000, command:02, direction:01, data:[00, D4, 65, 01, 00, 01, 00]]

[dev:121/logs?tab=past&deviceId=121#)2023-07-31 04:38:25.309 PM[warn]logs?tab=past&deviceId=121#)Tuya unknown attribute: 00D4=65=0100 data.size() = 7 value: 0}