[RELEASE] Tuya Zigbee mmWave Sensors (code moved from the Tuya 4 In 1 driver)

I observed the same situation this morning - my SNZB-06P settings have been reset for some reason. Why and when - it is unknown.

I tested the Refresh() command, and it works as expected. If I turn off the device power supply, then change the fading time and the sensitivity (while powered off), then wait 30 seconds and power the device back on. The Preferences showed the expected settings ( 300 seconds and sensitivity 1), but these were actually never sent to the device, as it was off at that time. When I click on the Refresh button, the device reports the actual settings (sensitivity 1 and fadeTime 15 seconds). Pressing F5 on the device page showed that the Preferences were corrected back to 1/15, as the device's actual settings are.

So the driver is working as expected, but it is unknown why the device has reset its settings and at what time.

BTW, you can make a RM5 rule to dynamically set the sensor parameters - for example to extend the fading time during the night, when it is expected to detect a sleeping person.

Click on the SetPar button (without any parameters)

The list of the available parameters (Preferences) that can be set will be dumped in the live logs:

In RM5:

  • choose 'Run Custom Action',
  • capability of action device * Motion,
  • select custom command 'setPar'
  • add parameter of a type String, string value : fadingTime (or radarSensitivity)
  • add another parameter of a type String, string value : value 15 (seconds)

    Note, that the custom action setPar parameters must be of a type String.

Then you can add as a trigger a specific time of the day to automatically change the sensitivity and the fading time of the radar.

Update: 10 hours later, I found my SNZB-06P settings reset again (were 1/30, reset to 2/60).
No motion was detected, and no power-off events during this period.

Device Software Build Id:1.0.5

A useful picture from this link: Review of SONOFF SNZB-06P human presence and SNZB-04P door/window Zigbee sensors - CNX Software


I have the following device
Tuya Zigbee Human Presence Detector,Luminance/Distance Detection, Smart PIR Motion Sensor Support Zigbee 2mqtt Home Assistant

I am using the following driver: Tuya Zigbee mmWave Sensor
With the device profile set to: Tuya TS0601_2AAELWXK 24 GHz +PIR

Current States

  • Status : clear
  • fadingTime : 30
  • healthStatus : online
  • humanMotionState : none
  • illuminance : 120
  • ledIndicator : 1
  • motion : inactive
  • staticDetectionDistance : 6.0
  • staticDetectionSensitivity : 6

State Variables

  • deviceType : mmWaveSensor
  • deviceProfile : TS0601_24GHZ_PIR_RADAR
  • lastTx : {cmdTime=1716398156261}
  • lastRx : {batteryTime=1716398080606, checkInTime=1716398033962, illumTime=1716398094574}
  • stats : {cfgCtr=2, battCtr=8, rxCtr=69, txCtr=8, illumCtr=17, rejoinCtr=1}
  • driverVersion : 3.1.3 2024/05/11 9:46 AM (TS0601 _TZE200_2aaelwxk) (C-7
  • health : {checkCtr3=0, offlineCtr=0}
  • motionStarted : 2024-05-22 13:14:04.541
  • states : {isRefresh=false, isDigital=false, isPing=false}


  • endpointId: 01
  • application: 91
  • manufacturer: _TZE200_2aaelwxk
  • model: TS0601
  • tuyaVersion: 2.1.1

Is it not possible for the battery level % to be reported in the Current States?

1 Like

@kkossev can you please help?
I just added Tuya TS0225_LINPTECH 24Ghz Human Presence Detector and I used the Tuya Zigbee mmWave Sensor driver.
Previous to Tuya Zigbee mmWave Sensor driver, I was using Linptech 24Ghz Presence Sensor ES1 driver. With the Tuya Zigbee mmWaze Sensor Drive:

  • Illuminance is not avaialble
  • Motion is active
  • occupiedTime never reset and keeps on increasing. I believe this is the presence state, please correct me if I am wrong.

Can you please let me know what is wrong and how to fix it?

Can you manually update the driver to the new version 3.2.0 2024/05/24 6:07 PM?
There are no new features in it; just updated with the latest versions of the library files to align with the same code that I use for testing.

If your device still shows motion active after the update, in the "Set Motion" drop-down menu select 'inactive' and then click on the button above :

Do you see any errors in the live logs?

how do I manually update the driver?
It is finally showing the illuminance but the motion change to active to inactive is quite unstable. Currently it is stucked to Active after the Occupied time hit higher than 200.

I have enabled debug logging for 24 hours.

I will update the driver Wiki pages with detailed instructions on manually updating a custom driver later tonight. However, the reason for the motion staying active for a long time is probably not in the driver version.

Have you tried decreasing the two sensitivity parameters even lower? Also, check for possible interference sources.

I have updated both be 3 now. There is no interference source because it is just a rectangular room with TV, sofa at the back and 1 working chair in the middle where my son sits to play.
Shoud I just monitor and tweak the settings for now?

I have a similar room and I put the radar behind the couch pointing at my back and turned down the distance and sensitivity.


Yes, decrease the sensitivity settings even lower, until the motion attribute switches reliably to an inactive state.

I often create a test dashboard with a motion sensor tile when monitoring the performance from my mobile.

Have in mind, that sometimes the attributes on the device web page do not update automatically. It doesn't happen all the time, but sometimes the states need a browser refresh. That's why I am using a test dashboard for monitoring.

1 Like

Thanks, I will tweak the setting to lower and monitor. Will too low setting e.g 1 or 2 will produce low result e.g person still sitting but not detected?
I transferred to device to Home Assistant which seems to update without no lag so can I just create the test dashboard in HA?

Is the device paired to HA (ZHA or Z2M) now, or it is paired to Hubitat and exposed to HA via the Hubitat integration?

Device is paired with Hubitat and exposed to HA via Hubitat integration.

Yes, you could use the HA dashboard for the tests... First, ensure that when you manually force the motion state inactive/active, this is reflected on the HA Lovelace dashboard (nice name!)

1 Like

I have found and fixed a problem in yesterday's version 3.2.0 that was affecting the Tuya models.
(Linptech was OK). The new version is 3.2.1 2024/05/25 9:57 PM

Only these, who have instaled the driver for a first time or have updated it manually yesterday will have to update again to the new version 3.2.1. The previous versions prior 3.2.0 should be OK.

1 Like

I am trying to turn off the LED indicator mode on my Tuya TS0225_LlNPTECH 24GHz Radar. Here are the device details:

  • Manufacturer: _TZ3218_awarhusb
  • Model: TS0225
  • Tuya Version: 1.0.5

I am using the following driver:

  • Driver: Tuya Zigbee mmWave Sensor
  • Driver Version: 3.1.3 (2024/05/11 9:46 AM)
  • Device: TS0225 _TZ3218_awarhusb (C-7

I have noticed that I need to have version 1.0.6.


As I am new to using Tuya devices with custom drivers, I am unsure how to update the driver version using Hubitat. Could someone please provide the steps to accomplish this?

The device (not driver) needs f/w 1.06. There's no way to update the device f/w via Hubitat currently; that would need to be done using a Tuya gateway.

That's unfortunate. Thank you for the information @hydro311 .

Can anyone recommend an inexpensive Tuya gateway that works in Canada or the US and is readily available on AliExpress? I assume I would need to install the Tuya app on my phone, pair the sensor with the Tuya app, and update the firmware (not the driver). Then, pair it back with Hubitat. Is that correct?

@DGBQ my advise will be to pay just a little bit more and get the cheapest Tuya Zigbee Zigbee 2 Matter Gateway that you can find in the moment.

In addition to receiving OTA updates for all your Tuya devices, you can alternatively use the Tuya GW to bring the devices to Hubitat via Matter, paired to their native hub.

1 Like

Hi @kkossev,

I installed this via HPM. My driver version is 3.1.3 (I checked it from HPM and the driver code).

Tried to check for updates and do modify from HPM but it says I don't have updates to install.

Why is that? How can I update to the latest version?