[Release] Tasmota Sonoff Hubitat Driver & Device Support

Yep, it is the common technique to use when the firmware is > 50% of the storage size. Flash to minimal and then update the firmware. I have had a lot of success updating OTA, but some people have a failure if they had previously flashed a firmware with different "compile time" settings. Like the "Flash Mode" setting in Arduino for example. I have used the recommended Tasmota settings for compilation, but I don't have a way to know what was used on the device before.

So, if there is a failure for that reason, the device may need to be reflashed over a serial connection.

Also check though, if the device does not show up on your network after an OTA, that it isn't just sitting back in its access point broadcast mode waiting to be connected back to wifi. I've had this happen a few times too.

I'm having a few issues after following all instructions. When copying drivers/apps I just link the raw files which seems to populate just fine. What I have done so far:

From what I have read, I am using an SC20, basically a Tuya device with HLW8012 sensor, seems pretty generic.

I am not able to auto discover the device in the Sonoff (Connect) App, when I go to manually add it I get the below error:
com.hubitat.app.exception.UnknownDeviceTypeException: Device type 'Sonoff Wifi Switch' in namespace 'erocm123' not found on line 93 (manuallyAddConfirm)

from memory I had to rename the device type in the driver to "Sonoff Wifi Switch" from "Sonoff S20 - Tasmota"

Spot on, that was exactly it.

@ericm is this by design?

Not really, I just haven't had the time to give the app and drivers the attention that they need. If it was up to me I would have dozens more drivers with all bugs worked out of the app, but time is limited of course. :slight_smile:

Can you post the http://ip_address/description.xml here and I can add the device to the connect app to use the correct driver?

Don't worry, open source is just that. I need to take the time to understand the app and drivers better :wink:

<root xmlns="urn:schemas-upnp-org:device-1-0">
<modelDescription>iTead Intelligent Systems Co., LTD</modelDescription>

Just put it out there for reference anyone using the Sonoff bridge that these 433mhz door sensors have 2 different codes for open and close.

1 Like

I'm having trouble getting a non sonoff switch flashed with this firmware to talk to Hubitat. I was hoping that one of these drivers was going to be able to work with the generic module profile, but no matter what I try, it never works even after adding the IP manually.

Did you flash with Tasmota minimal then try and load this firmware? Also were you load any of the Tasmota firmwares?

Loaded the sonoff basic firmware that's included with tuya-convert, and then flashed the firmware from this thread. I have the Hubitat option under configure-other but it doesn't populate anything when I add it as a new device by IP. Maybe it's a driver issue? I'm not the best when it comes to throwing code down on a page. :sweat_smile:

Try this driver. [Release] Tasmota Sonoff Hubitat Driver & Device Support

Set the IP I’m the IP field. You’ll need to check the logs to get the MAC of your unit and set the DNI to that.


I added it the way I was doing it and changed the driver to the RPC one. Threw in the IP and it immediately worked. Thanks!

1 Like

Thanks for this.. I wonder which Sonoff device would be best to use to activate a garage door..

Hi dbmet

I use a Sonoff SV for my garage door. It needs to be modified so that the incoming voltage does not pass through to the output side. Very easy to do, you have to remove 2 resistors, but there are a few videos on YouTube.


I have the Sonoff SV setup to open and close my garage, this is working fine in Hubitat. What I need to ask is how I would display if the garage door is open or closed. I have a reed switch which I can connect to GPIO14 (I think) but how would I show this status in the Hubitat and the dashboards.

Have installed the Sonoff TH, is there a way to increase the refresh rate to read the temp/humidity? I find it does not update often enough currently. Looking at the events for the device the temp and humidity updates every 5 minutes
Thank you

From the Tasmota command line you can enter:

TelePeriod x (where x is the number of seconds between reports).

1 Like

@ericm Thank you very much for the info, will try this tonight. It seems to update instantly on the tasmota web interface it is just slow in Hubitat. Will this change the refresh period in Hubitat.

Thanks again.

Thank you that worked 100%, Learning everyday.

Thank you

@ericm First, thank you for writing this addition to Tasmota! Secondly, is there any reason apart from time you have not yet updated to the upcoming 7.1? If it's only due to time, I could try to find the time and help out doing it. If there's any other reasons, like due to serious bugs/incompatibilities that you know of, I'd love to hear about it before I get started on merging everything into 7.1.