[RELEASE] Tasmota for HE - Auto-detecting Tasmota drivers + Tasmota firmware 7.x/8.x for HE (for use with Tuya, Sonoff and other ESP devices)

It comes from having the Analog flag set in the template, the device should work without that. Set it back to 0 (None), delete the child and try to run Refresh, the child device should not come back.

Both ways work, my child device driver just have more settings. I designed the driver with the build-in components built-in in mind for those that don't want/need more than what they have to offer.

Go ahead, you can delete it. Not that it matters, if you don't open it, it will not run, ever. It doesn't subscribe to any events. It is designed to NOT run unless activated manually and used for installation and to look at the devices.
If you do delete it and then install it again, you will need to select the previously installed devices from the device selection list to have all functionality back.

They can also be exposed as a light by choosing my child driver for bulb/light instead of plug/outlet.

Thank you for pointing it out, will sort that. It should be consistent.

Nice to hear:) I love hearing back from people that use it!

1 Like

Just out of curiosity, do you know what that analog value is? It constantly fluctuates between 200 and 250 no matter the state of the two switches (but curiously your child device gets created only when I turn switch 1 on).
The device doesn't support power meter, so I have no clue what that is.

No, no clue, voltage? Some devices use if for a light sensor. Others for temperature.

:dizzy_face: That's exactly how I was flashing it. May be worth clarifying that in the instructions (unless I've been a dummy and just missed it!)

Just did it today, worked a treat. Finding the connection to short to ground to get it into bootloader mode was hard (it's resistor R19 on the Sonoff T1 UK) but once I found that it was up and running in minutes.

1 Like

I've added a small mention of it to the docs, but someone has to make a full guide for TTL flashing...

Yes, they can be a bit finicky, I use weighted pogo-pins to do it.

So Ill first off admit im new to Hubitat and Tasmota, but Ive been having a lot of fun learning.

The "configure" aspect of the parent driver doesnt seem to be working correctly for any of my devices. Which is why I was trying to figure out some of this over in Github issue, which has me now over here. Im running your 8.1.0 HE firmware and I think Im running the latest version of the driver & application.

When I issue the configure command, i see errors in the logs. Any ideas?

dev:762020-05-11 11:41:40.280 pm errorgroovy.lang.MissingMethodException: No signature of method: user_driver_tasmota_Tasmota___Universal_Parent_346.configuration_model_tasmota() is applicable for argument types: () values: [] on line 1294 (configure)

dev:762020-05-11 11:41:39.386 pm infoconfigure()

dev:762020-05-11 11:37:48.676 pm errorgroovy.lang.MissingMethodException: No signature of method: user_driver_tasmota_Tasmota___Universal_Parent_346.configuration_model_tasmota() is applicable for argument types: () values: [] on line 1294 (configure)

dev:762020-05-11 11:37:47.653 pm infoconfigure()

dev:762020-05-11 11:37:04.502 pm infoDevice info found: [hasEnergy:false, numTemperature:0, numHumidity:0, numPressure:0, numDistance:0, numSensorGroups:0, sensorMap:[:], numSwitch:1, isDimmer:false, isAddressable:false, isRGB:false, hasCT:false, hasFanControl:false]

dev:762020-05-11 11:37:04.086 pm infogetDriverVersion() = v1.0.2.0503Tb

dev:762020-05-11 11:37:04.082 pm infoUsing httpGetAction for 'http://192.168.105.130:80/cm?cmnd=Status%200'...

dev:762020-05-11 11:37:04.072 pm inforefresh()

dev:762020-05-11 11:35:09.908 pm infoDevice info found: [hasEnergy:false, numTemperature:0, numHumidity:0, numPressure:0, numDistance:0, numSensorGroups:0, sensorMap:[:], numSwitch:1, isDimmer:false, isAddressable:false, isRGB:false, hasCT:false, hasFanControl:false]

dev:762020-05-11 11:35:09.306 pm infogetDriverVersion() = v1.0.2.0503Tb

Well i just upgraded to the 512 version which must have been hot off the press. With that version, the device does get configured properly.

I also have setup a mqtt server. It might be nice to have a way to automatically set that up as well via the Tasmota Manager.

@cavanaughwww welcome to the community!

Yes, that comes with fixes for this issue. But also a lot of restructuring in preparation for future changes, so might have some minor bugs, please report them :slight_smile:

I'll have that in mind :slight_smile:

Hi,
I've successfully added a Sonoff Basic R2 to my Hubitat using the instructions, drivers, and apps provided. Thank you! It was fairly straight forward to do using your instructions. I am able through Alexa to turn the Sonoff on and off.

However. if I ask Alexa for the status of this switch it states this device "doesn't support that".

Is there anything I can do to add this supervision capability? (If that's what you call it?)

Thanks,
Steve

1 Like

Welcome back to the community!

Happy to hear that :slight_smile:

Which child device driver is it that you are using? The built-in one or one of the two I have? One is for exposing as a plug and another as bulb.

I'm not sure which 'child device' I used... sorry. Still rather new to all of this. Here's an image of what I have if that helps?

You are using "Generic Component Switch" which is the built-in one. You could try one of my child device drivers, either the one for Plug or for Bulb to see if you can get status with Alexa using that.

I'll try the Plug drivers.

BTW, could you please help me in verifying which of these boxes I need to check?

Press the Configure button on the device page in HE and it should be set properly. Try that and show a screenshot of this page again and I will know if it works. If it doesn't work I will guide you through what to do.

I can't find the "Configure Button" after selecting "Devices" in HE. Also tried selecting the child device and couldn't find this button.

The "Configure" button is on the device page for the device in HE.

To change the driver, select the child device at the bottom of the device page of the Parent device or from the Device list.
To change driver after having installed it the same way you installed the Universal Parent driver, select it from the dropdown on the device page of the child device. The dropdown is under heading "Type" in "Device Information".

I think it was successful with the Plug driver:

Here's a snap of the device page. Still can't locate the "configure' button.

Yes, now you have the right driver.

The configure button is on the Parent device, link at the top left corner.

Ah. Found it. Pressed it. I think you wanted this screen again after pressing Configure?

It didn't work as expected, please change to the development branch version of the Universal Parent. Then Click Configure on the parent device page again and check that "Hubitat /Smartthings enable" is checked. There are more things than that which will be set, but that is a good indicator.