[Release] Tado (Connect)


I am having an issue when I install the app.

After connecting to Tado, selecting the devices and selecting the presence devices, the setup gets stuck in a loop. I click done and it takes me back to the presence selection screen. No devices are created and the app isn’t installed.

Just out of curiosity, what Products are you using now that you have ditched?



I've just tried to install this too and likewise devices do not appear.

I wish I had the coding knowledge to have a look at fixing this. Anyone else able to have a look?


I have this installed OK.
Have you installed these 3 drivers?
Tado Heating Thermostat
Tado Hot Water Control
Tado user Presence

1 Like

Yes I just got there on my own it was stupidity.

When you go into the New Driver dialog I was trying to save time. I c&p'd the first one, saved then just c&p'd all the others into the same window assuming it would save a new one each time - it doesn't. So when I was looking through the logs it was complaining of no defined device which got me thinking. Lo and behold I only had User Presence (the last one I C&P'd) and not the first three. Sorted that out, re-ran the app and it all seems to work.

Apologies for crying wolf it's my first proper day with the hub and migrating everything across from my Vera. Still in the mode of thinking everything is broken (as it seems to be on the Vera)

I'll get there. Thanks for the quick response.


1 Like

Hi all,
i have this error when selecting hub id during setup: Error: No such property: id for class: java.lang.String
No hub is displayed so I have to insert it manually?
in. the log:
app:1362019-01-03 08:25:04.230 errorgroovy.lang.MissingPropertyException: No such property: id for class: java.lang.String on line 390 (advancedOptions)

app:1362019-01-03 08:25:04.217 debug[[HEATING|1|Riscaldamento Giorno:Riscaldamento Giorno], [HEATING|3|Riscaldamento Notte:Riscaldamento Notte]]

app:1362019-01-03 08:25:04.216 debugExecuting parseZoneResponse.successTrue

app:1362019-01-03 08:25:04.216 debugOutput status: 200

Same issue here - any resolution?

Is the Tado Internet Bridge needed to make this app work? Or is it possible to do this with HE?

Hi, welcome,

The Tado bridge is essential to make Tado to anything that involves third party services. All commands to your heating go via their API and servers then down to your heating.

Hope this helps.


first of all thanks a lot for this, it worked perfectly and discovered all my tado thermostats and radiator valves. Also the AC thermostat.

I have a few minor problems on status: it reports the valves as requesting heat but in reality they are not. I think something might have changed since the dev wrote the drivers.

The main problem though is that I'm not able to get the tado devices get discovered by Alexa. I configured the devices to be discoverable in the Amazon Echo device config, like I did for other kind of devices, but they're not being picked up by Alex after discovery of new devices.

Anyone managed to make the integration work?

Thanks for any help. :slight_smile:

Works perfectly! Thanks!

I also have Tado connected to Alexa. I don't experience the issue you describe. Did you enable the Tado and Hubitat skill on Alexa?

I fixed my above issue but the tado app is flooding my logs and I can find a way to control the logging options? It looks like its contantly set to debug logs and as Hubitat's logs are not ever lasting tado filling it up is knocking out information that I need for other drivers!

OK so I couldn't find a toggle to control debugging so I went through each line of the logs I didn't want to see anymore and then found the correlating log.debug command in the app code then remove that and tested after each removal. now seems everyhting is working great and i'm not getting 12 messages a second from Tado Connect :slight_smile:

I am throwing out one error though if this topic ever gets someone else that has it / shows how to fix it:
___exception: java.lang.NullPointerException: Cannot get property 'atHome' on null object

I can only see that property used twice in the app code and i'm not 'codey' enough to know what the issue is!

I'm using this app but I'm not seeing that error in the logs.
I'm not a coder either but as there is a reference to "atHome" could it be something to do with presence detection.
Have you got that set up and if so is it set up correctly.
Just a suggestion, but like I say, I'm not a coder either.

yup the presence detection broke as Tado changed the API for presence detection in v3 of the app. all other functions still work though.

Thanks, Does that mean that prescense detection doesn't work at all with this driver in Hubitat? I've set up a few rules using that prescense information but obviously, due to virus lockdown, haven't been able to leave the house to try them. I'll rebuild those rules to use hubitat phone presence if the tado prescence driver doesn't work I was only using this as it already has my extended family phones prescense as they have the app for my heating system so i use it to track them when they're arriving so I can prepare to deal with my in laws...... :wink:

Tado presence detection is still working for me.
As the Tado connect app polls Tado every 5 minutes, it can take up to 5 minutes before the presence state is updated in HE.

Still working for me as well.

Hi, how did you go about this did you just delete each line with debug or something else? I'd like to get rid of all the debugging messages....sorry I'm not a coder either.