[RELEASE] Sonoff (Connect)


#122

The Kogan is a Tuya based device. You could flash it with TyuaConvert to a basic Sonoff firmware and then try @ericm's firmware on top of that. But, be warned that it's a pain in the a$$.

This is why I HATE Tuya-based devices. You have to jump through multiple hoops just to flash their devices to something that doesn't report your data back to some Chinese server farm.


#123

@corerootedxb, @Ryan780 I flashed it initially using TuyaConvert to a basic Sonoff firmware and then applied @ericm's firmware on top of that and that's where it seems to have bricked the plugs.


#124

Ahhh, gotcha. sigh Any chance of getting real Sonoff plugs? :wink:


#125

I've actually worked a little bit on a Hubitat / SmartThings driver for the Tasmota firmware. Since Tasmota is such a great project and has support for so many devices, I figured a driver would be the easier route (easier than trying to release support for every device). It works with all the devices I have tested so far (S31, S20, 4-Channel, Bridge, and more.). The drivers need to be written for other devices, but it isn't difficult to do.


#126

I've just flashed a sonoff 4ch pro r2, when trying to connect to it its asking for a password, any idea's?


#127

configme maybe?


#128

Thanks Roy, I did search.


#129

I just remember having the same issue lol. So it’s now stuck :wink: I was fairly sure it was that, hence the “maybe” :+1:


#131

Do you have firmware for sonoff rf bridge... I need to use with 433mhz rf sensors


#132

configme


#133

I came across this Sonoff device on Ebay, It has a low current consumption and therefore ideal I think for outside battery powered use. Can it be flashed for HE control?


#134

how to connect sonoff rf bridge to hubitat?


#135

You can try my fork of the Tasmota firmware. It has support for the bridge, but the Hubitat bridge driver needs a lot of work.


#136

hi, just flashed my switch with the firmware and i can't access it anymore, is there anyway to reset it or is it bricked?


#137

Search for the new WIFI ssid?


#138

What method did you use to flash the new firmware? If you erased the whole flash, then you have to go back to step 1 in the setup and search for the device and add it to your wifi again. Remember, all that is stored in flash too.

The real indicator if it is bricked or not is the on-board button. If you can turn it on or off with the button then it isn't bricked. Also, it is possible that it did not flash correctly. Some models of sonoff respond well to one mehod of flashing and others do not. For example, the ones that I have had to be flashed using the ESP8266Flasher tool. Other methods would not work at all.


#139

i flashed using the tasmota web gui ... onboard button has no reaction, weird though after the switch is plugged in it turns on after about 20 seconds on it's own


#140

Which firmware were you trying to flash? Eric's custom firmware to use the Sonoff Connect app or the Tasmota firmware to use Eric's Tasmota Driver. If the latter, you might want to post over on that thread as that will be more likely to keep things straight.


#141

It said it installed correctly but did come back after reboot


#142

Yes, I ran into the same thing too. I had to use the ESP8266 flasher tool to get it to install correctly.