[RELEASE] Send IP2IR - Control all of your IR devices from your Dashboard


I've only tried it with the device listed in the first post but it should work with any of the IP to IR devices that Global Cache sells. The flex is just a smaller version, easier to hide. It should also work with the wireless to IR, as long as they are on the same network, it'll send the code.

Great thing about Amazon is the return policy...make sure you pick a vendor that will take it back, no questions asked (most will). That way if you do have any problems, just send it back.

If you do try it, please let us know that it works and I'll add it to the post.


Is this app working OK for everyone? I used an earlier version for a while and it worked fine, but due to some Zwave issues I had to remove it all while we were testing as support said it was throwing up some errors. My system seems a bit more stable now I've just tried loading it again using the latest versions of driver and apps. I am getting the following errors is the live log and it is not establishing a telnet connection.

dev:11562018-12-06 12:29:13.641 pm errorjava.lang.InterruptedException: null on line 109 (telnetStatus)
dev:11562018-12-06 12:29:13.616 pm errorTelnet connection dropped...
dev:11562018-12-06 12:29:13.615 pm debugtelnetStatus: receive error: Stream is closed
dev:11562018-12-06 11:57:14.079 am [error]
dev:11562018-12-06 11:57:14.079 am errorTelnet connection dropped...
dev:11562018-12-06 11:55:48.187 am debuginitialize error: Connection refused (Connection refused)


Read up above around the Nov 4th timeframe. If it drops connection it doesn't reconnect automatically.


@bptworld you could include a function to kill the telnet connection that Hubitat has with the device:

This may solve the requirement of rebooting the hub if the IP2IR is restarted.


Yes, I did read that, but I'm trying to connect for the first time since install using the IP2IR device page initialise button. Does that mean I have to reboot the hub after I have installed the device driver?


don't remember but I'd give it a shot


Possibly a way to test the connection and reinitialize if lost? The built in DH for the Denon receivers seem to do this ok.


Sorry, to see there is some problems with the driver. I have a new version in Github now. It doesn't completely solve the issue but I'm working on it. In the meantime, there is a very simple way of getting it working again. Anytime you have to reset you IP2IR device for any reason, just go into the IP2IR Telnet device and press the 'Initialize' button. Everything will be good again.

Driver Update:
V1.0.2 - 12/06/18 - Minor changes and additional error message. If the IP2IR unit is unplugged or loses connection for any reason, simply go into the IP2IR Telnet device and press the 'Initialize' button.


What a speedy response! Working perfectly for me now. Thanks very much for the app and the great support. Got to love the Hubitat community :+1:


One question about the child set up - is it necessary to enter the iTach IP address again for each child? Doesn't selecting the specific IP2IR device determine the IP address of the device anyway? Or could a child access a different Itach (if you had more than one) from the parent?


Good catch, it's not needed at all in the child apps. It doesn't hurt anything but it also doesn't do anything. :sunglasses: It's just a leftover from a much earlier version. I'll remove it and post an update soon. Thanks!

To use the app with two iTach devices, you would just have to make a second IP2IR device. Then choose that device in the child app.


New Version:

V1.1.5 - 12/06/18 - Code cleanup, removal of IP Address from Child Apps as it was not needed anymore.


The driver is no longer in git on the URL in this thread - does it still work/exist somewhere?


It’s still there:


New version on Github...

V1.1.6 - 12/30/18 - Updated to my new color theme.


Just for info, I have had some Zwave issues recently and while support were investigating they said I had a lot of Telnet errors on restarts that were causing knock on issues. Once I reinitialised IP2IR things started running again but I ended up removing IP2IR at the advice of support while they were investigating. The errors were not ones that I could see in my user log, but only visible to support, or I would let you know what they were. I don't know if this was just specific to my system but it might be worth checking with @bobbyD for details in case it's a general problem with the driver or app.


I think I had the same issue. This was the only app I didn’t reinstall after stripping out all custom things and my system is running fine still.


@bptworld, there was discussion about apps having issues reinitializimg after reboots in the thread below. Might be worth a read, especially Chuck's advice a couple of posts down.

[Beta Release] Logitech Harmony Hub Driver v0.1.20181227


Well, I would hope that @bobbyD would contact me if there was an issue with my app. I've been running it for months with no issues at all. It is used every single day.

The only issue someone has mentioned is if they unplug the device for any reason, then you would need to go into the device and hit Initialize again. This is documented in the first post.


Thanks, I took a look at that post and the 'capability "Initialize" they talk about has been in my driver since day one.

I guess it just comes down to checking the logs. If you think there is any problem, clicking the Initialise button again should solve it.