[RELEASE] Panasonic AC - Comfort Cloud

Features:

  • Full device discovery and pre-selection
  • Hierarchical device import and actions (Group -> Device)
  • All Groups and Devices attributes are collected
  • Configurable logging levels
  • Scheduled State Check
  • Automated installation with HPM

Status: Fully tested and working

Todo: Nothing for the moment

Download: GitHub

1 Like

Hi There, i cant get it to work... the App connects and sees my Airconditon, but no devices are created...

when creating a manual virtual device with the panasonic driver, nothing gets registered either..?

what do i do wrong?

Your device must be of another type as the ones I have tested with.

Please PM or email me the full output of the application state details, so I can debug and fix the issue:

Nz25vke

Please send me ths full texts group and device details fields, thats what I need to find the issue

I have installed using HPM, successfully logged in

App logs:

Looks like it fails to create devices due to above error. I see above @diondp having same error and you requested " full texts group and device details fields", how do I get those in Hubitat for your app?

Any other suggestion will be greatly appreciated

Hi @syepes I see you updated app (HPM told me there is an update). I installed it and now, device and child device (as named in home comfort app) have been created (screenshot):
image
I can now switch it OFF using AC01 device, but once it's switched Off, I can't switch it on using device and I see following logs:


Thank you for update, it's seems so something working but not everything...

it's again giving same error

deviceDetail HashMap {CS-NZ25VKE+4971106100={deviceType=3, modeAvlList={autoMode=1}, coordinableFlg=false, modelVersion=1, groupId=83275, summerHouse=0, permission=2, autoMode=true, deviceName=stue, nanoeStandAlone=false, groupName=My House, deviceGuid=CS-NZ25VKE+4971106100, temperatureUnit=0, name=stue, deviceModuleNumber=CS-NZ25VKE, deviceHashGuid=a17371bcd1ee652d488bd3a2ec2d899d452587edb944cfb37ffd40af714c56f5, id=CS-NZ25VKE+4971106100}}

groupDetail HashMap {83275={groupName=My House, groupId=83275, name=My House, id=83275}}

I'm trying to log in in the app, but keep getting error "Unable to connect to Comfort Cloud, double check your credentials. Click Next". Any known issues?

Using e-mail an PW, have triple checked that it is correct.

it needs 2FA, since the update of the comfort cloud app. somebody who's able to adapt this driver to that?