[Release] Nyckelharpa, an HSM Extension

The app's main purpose is to allow for a contact sensor to be open while arming the HSM system and using arming failure warnings. Other sensors may be monitored by HSM. Motion sensors may and generally are active when arming especially in Home or Night mode, hopefully a smoke detector is not.

HSM has two rather obtuse arming settings:

  • When no arming warnings (notification, device, etc) are set, HSM silently arms when any sensor is open or active.

  • When any arming warnings (notification, device, etc) are set, HSM will not arm. Hence the suggestion to set a virtual device when no other warning is set.

Nyckelharpa attempts to set a middle ground with a third setting: Warn the user, then allow the next attempt within a specified time period in seconds to arm the system.

1 Like

Thanks for getting back to me so quickly. My suggestion would only apply if the alarm was activated while you weren't present. And then couldn't be re-armed due to a faulty motion or smoke detector. However if it can't be it can't be. Thanks

I understand your concern.

I feel motion sensors can be eliminated as a concern, HSM arms when motion sensors are active. The real issue may occur when a motion sensor produces false triggers while you are away. I had this occur, a fresh battery cured the problem.

Smoke detectors are a whole other issue, but I don't believe it impacts HSM status arming.

Being able to get into the hub with a VPN is a wise choice.

I didn't realise it arms when they're active? I don't need to worry as mine is armed and disarmed by presence. Thanks for getting back to me.

What it is attempting to say for paragraph 2 is

  • standard HSM does not respond to panic requests when the HSM system is disarmed.
  • With Nyckelharpa and a properly configured HSM panic rule, panic is honored when the HSM status is disarmed.

[Update] Dec 15, 2020 13:29EST

What Changed

  • Keypad device attribute lastCodeName contains the name of last accepted pin code. Lock Code Manager and Nyckelharpa pins supported.

  • Added support for proprietary, EU only, Centralite 3400-D keypad with 6 digit pins

  • Centralite-Keypad driver: Minor code change reducing trace and event logging overhead

How to install
There are 2 modules associated with this update. Manually update, or use the Hubitat Package Manager. No post installation update required.

Posting Update: Had a report HPM would not update this package and encountered same. Should HPM not update this package, use the Repair option for this package.

App Code

  1. Nyckelharpa (V1.2.1)

Driver Module

  1. Centralite-Keypad (V1.0.5)

Post installation instructions

  1. None

Source Code and Documentation

Thanks

I'm new to Hubitat, I might have missed something. I put both the App Code Nyckelharpa (V1.2.1) and the Driver Module (Centralite-Keypad (V1.0.5) into Hubitat and neither gives me the "panic" button feature optionI'm looking for. Acutally it renders my Iris V2 3405-L useless. Suggestions?

Did you follow all the directions in the documentation paragraph 13, create a HSM custom panic rule?

Is there a way to prevent talker from saying "you have 30 seconds to exit the facility" when selecting Armed - Home and only say it for Armed - Away?

Unfortunately not. However you can change the message to something like "system arming in %nn seconds"

I am having trouble getting beeps when a door contact is open and for a countdown when the system is armed. I am using Piezo buzzers with a Konnected alarm board. These are what I have in global settings:

And this is my log around the time I opened a door to test:

app:682021-02-17 09:14:30.394 am traceIn cmdHandler...

app:682021-02-17 09:14:30.060 am traceIn updateMembers - (2.6.0)

dev:1132021-02-17 09:14:27.281 am infoDining Room-Motion is active

dev:92021-02-17 09:14:25.967 am infoFront Door Lock was manually locked [physical][6:1]

dev:92021-02-17 09:14:25.965 am debugalarmv2.AlarmReport: AlarmReport(alarmLevel:1, alarmType:21, eventParameter:[], numberOfEventParameters:0, zensorNetSourceNodeId:0, zwaveAlarmEvent:1, zwaveAlarmStatus:255, zwaveAlarmType:6)

dev:92021-02-17 09:14:25.960 am debugparse: zw device: 09, command: 7105, payload: 15 01 00 FF 06 01 00 00 , isMulticast: false

dev:12021-02-17 09:14:25.752 am infoDen Motion is inactive

dev:1052021-02-17 09:14:20.800 am infoFront Door-Sensor is closed

dev:1052021-02-17 09:14:15.870 am infoFront Door-Sensor is open

dev:92021-02-17 09:14:15.336 am infoFront Door Lock battery is 100%

dev:92021-02-17 09:14:15.334 am debugBatteryReport: BatteryReport(batteryLevel:100)

dev:92021-02-17 09:14:15.304 am debugparse: zw device: 09, command: 8003, payload: 64 , isMulticast: false

dev:92021-02-17 09:14:14.795 am infoFront Door Lock was manually unlocked [physical][6:2]

dev:92021-02-17 09:14:14.792 am debugalarmv2.AlarmReport: AlarmReport(alarmLevel:1, alarmType:22, eventParameter:[], numberOfEventParameters:0, zensorNetSourceNodeId:0, zwaveAlarmEvent:2, zwaveAlarmStatus:255, zwaveAlarmType:6)

dev:92021-02-17 09:14:14.715 am debugparse: zw device: 09, command: 7105, payload: 16 01 00 FF 06 02 00 00 , isMulticast: false

dev:1132021-02-17 09:14:14.545 am infoDining Room-Motion is inactive

dev:1132021-02-17 09:14:07.208 am infoDining Room-Motion is active

dev:12021-02-17 09:14:04.488 am infoDen Motion is active

app:682021-02-17 09:14:00.453 am traceIn cmdHandler...

Suggest removing the keypad from this setting since it kills any countdown tones on the keypad device. Also which keypad model is installed? Does the Alarm Panel beep?

I do not have an actual keypad. I have a FireHD tablet that I use to arm/disarm my alarm that I call a keypad. That device listed is Piezo buzzer that is located near my tablet.

I can remove it if necessary. I thought it would not matter since it was not a keypad.

If it's not a real keypad, then it should be OK.

How is the "Beep" tone created on the tablet and does it sound without using the Nyckelharpa app? Also are you using the built-in HE dashboard authorization keypad or something else?

I use two Fire tablets and two old Android phones for dashboards, announcements and tones. The devices use the Fully Kiosk Browser, Fully Kiosk Browser Controller device app, and some sound files loaded onto the devices for sounds and tones.

I do not have the tone created by the tablet. I have a buzzer near the tablet make the sound. The buzzer is part of my Konnected alarm system. It is setup similar to this:

Through the konnected alarm app a device is created called Keypad-Beep. That is what I selected to use for the beep in the Nyckelharpa Global settings. I can get the buzzer to beep turning it on in the device settings.

I do not have any keypad set-up in Hubitat. I am using the dashboard and hubitat safety monitor to activate and deactivate the alarm.

These are the device options I have for the buzzer, is there something in here I need to change?

Everything had been working fine, but then I updated to Nyckelharpa v1.2.1 and I lost the ability to arm HSM from my Centralitex keypad model 3405-L which I think is Iris V2. I was using the Nyckelharpa Centralite-Keypad driver version 1.0.3. I upgraded the driver to 1.0.5 and now I can arm the system, but I still don't have exit delay tones when the system is armed.

I tried removing Nyckelharpa ModeFix and reinstalling (no settings) which didn't work. In my keypad device, I can enter 15 for the "Set Exit Away" command and I get the normal beeping. When I try to enter 15 for the "Set Exit Delay", I get nothing.

I tried rolling back Nyckelharpa to v1.2.0 and then to v1.1.2 but that didn't fix it.

Any help is appreciated.

Before doing a deep dive into this issue, please update all the Nykelharpa modules and keypad driver to the latest versions. I prefer using the Hubitat Package Manager, although it can be done manually.

Exit and entry delay times are set in HSM.

The 3405-L is the Iris V2, that has a few firmware versions and beep commands. Should it not beep please try setting the following in the device. image

Thanks for the help. I've updated via the packet manager. I'm on Nykelharpa version 1.2.1. My keypad is using the Nykelharpa driver version 1.0.5.

The keypad is beeping, just not getting beeps after the alarm has been set to let us know the system has been armed.

I armed my system in away mode 30 second count down with an Iris V2 and after the last five seconds of fast beeps, it gave a long hardware generated beep when armed.
My suggestions are limited. They are:

  1. Try with the Old Style Beep setting on and off
  2. Turn up the keypad volume by holding the 2 key
  3. Use a speaker/TTS device announcing the arming and disarming. The Talker module supports this.

Download the Hubitat app