[RELEASE] Local tuya RGBW Bulb Driver


I mean ie as in example, I was doing this in Edge, and tried on Chrome as well. Will try firefox later today.

I was cut/pasting the key from the command line output, but I'll clear the cache file and give it another pull.

I'll update once I get a chance to do this, thank you!

Tried in various browsers on various computers, all give me the same, modifying this string

FO4:l6$gE{+JHA even here isn't showing it right... F < 0 4 : l 6 > $ g E { + J H A



HA! I was able to escape it:

F<O4:l6>$gE{+JHA "F & l t ; O 4 : l 6 > $ g E { + J H A"

Now it works!

Aha, now I understand, then it makes more sense. This is a protection to prevent HTML injection, & l t ; is indeed the HTML way of dealing with less than (<). I wonder if I can do something with the driver to overcome this issue. Thanks for pointing this out, and good that you found a workaround.

I think I have a fix for this issue in the latest updated driver, see: hubitatappndevice/Device/tuyaDevices/tuyaGenericBulbRGBW.groovy at master · ivarho/hubitatappndevice · GitHub

The fix seems to be to feed the escaped key back into the device settings.

// Update the setting in case < got replaced in the original input
device.updateSetting("localKey", [value: localKey.replaceAll('&lt;', '<'), type: "text"])