[RELEASE] Iris SmartPlug Z-Wave Repeater (3210-L + others)

This is a successful interrogation:

  • lastTest : Interrogation complete!

It will fail on one of the 6 steps and not continue. So a complete status is a good thing.

I have a few plug doing this too.. Wonder if Hubitat changed something in that command class.

1 Like

Interrogation completes. No problem there, I just never see a lastMsgRcvd that indicates it's repeating for the device in the area. Right now lastMsgRcvd shows null.

Mmmm... I'm getting this on "Interrogate Device".

lastTest : Device is responding!

And this on "Test Communication":

lastTest : SUCCESS 30 of 30 frames received.

Update: Nvmnd just ran it again and got "Interrogation complete!"

Good afternoon..

I have released a new version of this driver that takes advantage of the additional Z-Wave version reporting that was recently made available. It also improves compatibility with the upcoming release of HubConnect 2.0.

It fixes the null device version data that was recently reported. Please let me know if I've missed anything!


Works great.

1 Like

Thanks for the great work. I had a little trouble getting Zwave to pair but eventually found some more info about 8 button presses, all good now,

More Z-wave pairing info:

1 Like

If this is generic to Z-Wave repeaters, why have Iris in the name?

Thank you! Thank you! Thank you! Worked like a charm on my 3210-L. Had to Save Device, Save Preferences, Configure, Interrogate but otherwise happy. Thank you very much @srwhite.

EDIT: Spoke too soon. Took it to it's final location (still close to hub) and it lost communication. Will look into it.

EDIT2: It seems to not be able to go online after a power cycle. If I remove it from the system and re-include, it works great, until that power cycle. The Zigbee device works fine after a power cycle.
Any known reason why losing power would cause it to lose it's association with the hub?

If the plug is losing it's connection after moving to a new location, it's an indicator that it is out of range. I think you will find that if you move the plug back to it's "pairing" location, wait a couple minutes after plugging it back in, it will reconnect.

After you move the plug to its new location, after a waiting a couple minuted, run a Z-Wave repair. That will allow the plugs neighbors to learn of it's existence, assuming there are other device within range.

Thanks @srwhite I thought so too, but all I did during my testing was include it from about 2 feet away, configure, interrogate, etc. Then I just plugged and unplugged it in the same location (2 feet away). Once plugged back in, the zigbee worked but the z-wave repeater did not.

This behavior was replicated (al from 2 feet away) on three 3210-Ls. Do you think it might be firmware? All three have with the following:

I read one of your ST posts from 2018 and the firmware reported here looks nothing like it did on Iris (eg 0x20085010) so I can't be sure.

And here it is after a plug/un-plug in the same location (2 feet away):


You might just simply have a bad plug. Try leaving it connected for 15 minutes before unplugging and re-plugging, in the same spot.

It definately appears that the plug is losing its connection when disconnected.

Not sure if this is the right place for this, but has anyone here tried using these plugs, 3210-L, with an electric space heater? Specifically one that outputs 1500W. I found online that they only support up to 12A, and with 1500W, 120v, it draws 12.5A, but I was wondering if anyone had tried. Sorry again if this is the wrong place for this question, but this seemed to be the most active thread regarding this plug.

I use one for a small bathroom heater but only use it on the low setting, 750 watts. High or 1500 is bit too close for my comfort. FYI Zooz has a plug rated at 15 Amps


How are you guys handling energy monitoring using the 3210-L? I see that it reports the current wattage draw, but is that stored anywhere to get a KWh number or weekly/monthly usage? Is there a community driver/app that allows that?

Did you ever figure this out? Does the firmware get reported correctly? Is it the deviceMSR?

No. Never got it figured out. It's completely reproducible with three different 3210-L's. Whether it's with the generic driver or @srwhite's update, I can't seem to make mine work past a power cycle but I've decided it's something specific to my firmware. The zigbee portion works awesome, it's just the repeater portion that goes offline at first power cycle. I've just decided to purchase a Aeotec repeater and use the 3210-Ls as just switches.

Not sure if you have been following this new app, but someone has made a package manager that serves as a sort of storefront for downloading and installing new drivers and apps. I've been contacting all of the developers for the apps/drivers I use as he is trying to get as many people using it as possible. If you are interested, here is the link to the thread:

1 Like

I cant get mine to work. i followed directions, install driver, change driver in device, save, configure...

here is the logs:
dev:1972020-07-09 20:45:28.225 traceDevice Interrogation: Phase 1 of 6; Attempt 3 of 3...

dev:1972020-07-09 20:45:28.113 traceSending command... PowerlevelGet()

dev:1972020-07-09 20:45:23.134 traceDevice Interrogation: Phase 1 of 6; Attempt 2 of 3...

dev:1972020-07-09 20:45:22.970 traceSending command... PowerlevelGet()

dev:1972020-07-09 20:45:17.991 traceDevice Interrogation: Phase 1 of 6; Attempt 1 of 3...

dev:1972020-07-09 20:45:17.819 traceSending command... PowerlevelGet()

dev:1972020-07-09 20:45:17.778 traceInterrogating device...

dev:1972020-07-09 20:45:05.887 traceSending command... ManufacturerSpecificGet()

dev:1972020-07-09 20:45:05.844 debugQuerying device for manufacturerSpecificV2 information...

dev:1972020-07-09 20:45:05.825 debugPoll called, checking to see if device is online......

dev:1972020-07-09 20:44:14.536 traceSending command... ManufacturerSpecificGet()

dev:1972020-07-09 20:44:14.509 debugQuerying device for manufacturerSpecificV2 information...

dev:1972020-07-09 20:44:14.495 debugPoll called, checking to see if device is online......

dev:1972020-07-09 20:43:42.572 infoPeriodic health check is enabled but bypassed in the code.

dev:1972020-07-09 20:43:42.563 traceSending command... AssociationSet(groupingIdentifier:1, nodeId:1)

dev:1972020-07-09 20:43:42.557 traceSending configuration commands to Iris Smart Plug...

dev:1972020-07-09 20:43:30.318 infoPeriodic health check is enabled but bypassed in the code.

dev:1972020-07-09 20:43:30.305 traceSending command... AssociationSet(groupingIdentifier:1, nodeId:1)

dev:1972020-07-09 20:43:30.223 traceSending configuration commands to Iris Smart Plug...

More specific information please? Exactly what doesn't work? Zigbee? Zwave? Driver?

What happens in logs?

the repeater part of it when i install the new driver. it doesnt show me the status.

Current States

  • deviceMSR : --
  • deviceVersion : --
  • lastRefresh : 2020-07-09 23:51:11
  • lastTest : Contacting device... Errors: 9
  • lastMsgRcvd : null
  • assocGroup : --
  • powerLevel : --
  • status : offline