[RELEASE] HubConnect - Share Devices across Multiple Hubs (no longer SmartThings!)

For each HubConnect Instance, there's an individual selection for sending mode to that Remote. For My ST instance I have:

Screen Shot 2020-11-26 at 12.15.27 PM

With nothing explicitly set on the ST side:

And that works for me:

app:8 2020-11-26 12:14:25.859 pm trace  Sending httpGet [/modes/set/Day]to SmartThings hub ...
app:8 2020-11-26 12:14:25.855 pm debug Sending mode change event to SmartThings: Day

Took forever to find where the Mode is displayed in the New App. :frowning:

So after previous oversite I started over. Deleted all apps and started from scratch. Now I don't see ability to add oauth. I must be losing my mind or something. I am sure I am doing something wrong. This is my first step. No remote Hubitats.

is that screen shot from your server hub? my ST one is different?

i just noticed my other hubitat hub is not synching either . there is no mode options at all on that one

I got past my issue. I have one final question. When configuring the app on the HT, it says click install button on remote hub. I am unsure where to place the Oauth key in ST hub.

oAuth and 'the Key" are independent.

oAuth gets set in the IDE, when you added the Remote Client code.

The key is added via the ST mobile App inside the Remote Client app when it's running.

Because I've already added the Key, that image shows "hidden" where the key got pasted.

I have ordered a second hub with the intent of using the second hub to install the telnet version of the Envisalink/Honeywell integration. This integration is super chatty so I am going to load it on the second hub and use HubConnect.

I also have 2 Smartthings presence sensors that are also very chatty. If I load these 2 sensors on the second hub and mirror them to my main hub will they end up being chatty on both hubs?

1 Like


Assuming there's differences between reports. Do you mean this device: ??

Screen Shot 2020-11-29 at 10.55.19 AM

Because that device just sends a single 'check-in message" every few seconds.. I would not call that 'chatty.' However, you could use a virtual presence device as a 'filter' and just have a RM rule copy changes to the virtual presence and mirror just the virtual presence.

Yes, that is the device. In that case, I will just leave them on the main server hub. Thanks for the reply.

OK, I was sure I checked and did not see the app in my app to install. I rechecked and it is there. But now when I click on "Connect to Server Hub" the next window does not allow me to do anything. Any suggestions?

oh nevermind. i reinstalled and i got it.

Hi, what did you do to solve the issue? I am having the same problem. I try to connect to server hub (hubitat) and it doesn't give me any options to do anything. I deleted the smartapp from the ST IDE and re-installed and still no luck...TIA

v1.6.4 is not supposed to be able to work with the New ST App.

Screen Shot 2020-11-30 at 9.27.14 PM

v1.6.4 is expected to continue to work for Hubitat to Hubitat connections. SmartThings has said they have shut down their Classic App. The only code that is known to work with the new ST mobile App is v2.0 (and specifically RC2)

v2.0 is available via a free login to HubConnect.TO

Yea sorry for not explaining fix. I realized that and found somehow I got crossed up and grabbed wrong file. Reinstalled with the 2.0 fixed it

I recently moved to a new hub (restored the backup on it) and changed its IP address. I reconnected HubConnect to it and was glad to see it kept all the original devices so my automations continue to work.

I noticed today that the Remote hub Device on the Server hub still has the old hub's IP address. Is there any way to update the device to the new IP address (in a way that I won't lose the devices on the other hubs)? (It keeps throwing errors in the log...)

I tried the "Update child devices with new IP address?" switch on the new hub, but it didn't seem to change anything on the server hub's device IP address...

Trying to come up with a way to get notified if the SmartThings hub becomes disconnected. There an easy way to do this through RM?

My ST Hub connected to a C5 shows as a presence sensor. I believe It shows not present when disconnected.

1 Like

@srwhite - I just updated to the latest firmware expecting to move everything over to Hub Mesh as it was advertised as a better, more efficient way to connect hubs... however from some pretty basic testing I can see that it is very very fragile and unreliable, Sticking with hubConnect - it works perfectly.

1 Like

I have recently migrated from a C-5 to a C-7 hub. Since then, I keep seeing this in my logs. I wish I knew what to do to resolve it... Any ideas?

The devices still seem to be connected correctly, so really not sure what it means... Other than it does a great job at filling-up my log...

In case this is useful as well, here is the HubConnect device's configuration:

Anyone having issues with Arlo Cameras reporting motion from ST? Starting today they are no longer reporting motion. I know they have been updated the Arlo integration over on the ST side, so I had feeling this was going to happen. When I sync the devices it seems to read them but they are not reporting in on their own.

I switched mine to reporting motion through Alexa when I shut down my ST hub; was the only reason I had ST running, and when I figured out Alexa was working better than what I was seeing from ST or IFTTT...