[RELEASE] HubConnect - Share Devices across Multiple Hubs (even SmartThings!)

community_app

#364

No, you can run them side-by-side as you transition devices between them and Hubconnect. @csteele did just that when he was migrating a few weeks back.


#365

Good news @srwhite and @csteele

I got my 3rd hub cloud fixed so
20190328_172945


#366

I have everything over to HE but I wanted to use the ST app. And There are just a couple of things in ST that I couldn't migrate over. Mostly for the ST presence sensors and WC presence sensors.


#367

If I read that correctly, aside from the ‘why’ do you still want the ST app and if so..‘why’ migrate... you’re going to need the drivers to have ST versions with tile support. There are four drivers released so far with such, switch, dimmer, motion and contact.

There are a few solutions to your needs but holding onto the ST app is going to prove troublesome I think with most devices over on HE. Not an architecturally sound solution.


#368

Ok I am having an issue with virtual switches. I have ST virtual switches that are syncing with individually controllable switches on an Aeon power strip. I have two of these power strips so I'm trying to bring over the 8 switches. Below is an example of what is happening with all of them.

Hubconnect is bringing the device over to HE, ST is sending the on/off events.

6:30:07 PM: debug Sending event to server: Coffee Grinder [switch: off null]

HE is receiving the events

2019-03-28 06:30:07.530 pm [info](Received event from SmartThing Hub/Coffee Grinder: [switch, off , isStateChange: true]

But this is what my device page in HE looks like. No device states.

The device is also not listed as an option when selecting switches to control with other apps. Any thoughts on if I'm doing something wrong?


#369

What device driver is that device using? Can't see from the screen shot.


#370

It was power meter. change it to switch fixed it. Thanks!


#371

Ok one last problem device.

Has anyone successfully used a valve in HubConnect? I've selected the valve in my ST app. I'm not getting any error message in ST logs or HE logs related to the valve when I try to add devices. But the valve is not being created in HE.

One thing I've noticed is that "HubConnect Valve" is not showing up in the required drivers section of the ST app where it tells me what drivers I need. I do have the driver installed. But the other drivers I have installed still show up as being required. Not sure if that is related.


#372

I can confirm the same as @greg. I just tried to send my valve to ST but did not transfer. Nothing in the logs about Sneding devices to remote like the other items I have selected.


#373

Valves are a known issue that came up the other day when I was working on adding tiles to the SmartThings driver.

The fix will be in the next release.


#374

I have 2 client Hubitat hubs connected to the server hub. They are all on the same local network. One of my client hubs is constantly throwing the error code as offline in the logs. Its showing online in the main apps page and I can control devices on that hub from the server hub. I am having no issues with my second client hub. Any ideas because the hub that is saying it is offline is definitely not?
30%20PM


#375

If this is offers any clues, device health intentionally involves the remote hubs contacting or pinging the server hub. So what you have is one-way communication right now.. You can have outbound communication from the server to that client, but in return, do to a key or IP issue, the return path comunications do not work.

It could be something as simple as the remote hub having a bad token or IP address. Since I am sure you already checked to make sure the IP is correct, I would try copying the connection key from the servers Master Wing instance and pasting it into the connect key setting on the Master Wing hub remote client.


#376

Thank you! I will try that when I get home tonight.


#377

Hi. I'm seeing this in my logs under SmartThings Hub:

2019-03-30 03:12:52.434 pm [error]java.lang.IllegalArgumentException: null on line 794 (registerPing)

Can someone let me know if this is an issue and what I can do to remove fix the error?

Thanks.

--JKUDave


#378

That line is in the routine that is saying a Remote Hub is offline. The error is due to no IP address. If the Server has an invalid IP address for a Remote Hub, it will throw that error.

Each child app of HubConnect on the server needs to have a 'friendly name' of a Remote Hub and a valid IP address for that Hub.


#379

Hello, is thermostat available? I want to transfer it from ST to server to remote HE. Thanks

Edit, found it in HE server to remote HE, let me see in ST


#380

I discussed adding a horrible Virtual Thermo to ST expressly to test HubLink's ST to Hubitat abilities. :slight_smile:


#381

Thanks, I have the Honeywell wifi thermostat, I have the driver installed in HE, I believe it's yours, but maybe was better the ST integration transferred to HE? What do you think?

By the way, this HubConnect is faster than HE integration, I created a group of lights and it's instant!

Another question, I installed the remote hub driver but I don't see the remote hub in the devices in the server hub, is that fine? Everything works.


#382

I connect the WiFi thermostat to ‘coordinator’ and I could distribute a virtual thermostat into ST but I don’t have that need.

No, that’s. Not right. There should be a virtual hub on server for each remote hub.

Be certain you have a remote defined (child created) in Server

Then on the remote go into remote client and verify the IP Address and the key. Click done out and the server hub should have ‘tied together ‘ the physical remote to the child and create the virtual.


#383

I have this on the server

But no hub on the device list.
Edit, is not working, I can only see devices from server to the remote hub but no devices from remote hub on the server.